summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-08-21 10:45:02 -0400
committerAnthony G. Basile <blueness@gentoo.org>2020-08-21 10:45:20 -0400
commit15df26147f96fc707a5427c6323d6f96cd64ba2e (patch)
treea7b1921157380a2c9686df6d3644651564502f98 /app-text/xapian-omega
parentdev-libs/xapian-bindings: version bump to 1.4.17 (diff)
downloadgentoo-15df26147f96fc707a5427c6323d6f96cd64ba2e.tar.gz
gentoo-15df26147f96fc707a5427c6323d6f96cd64ba2e.tar.bz2
gentoo-15df26147f96fc707a5427c6323d6f96cd64ba2e.zip
app-text/xapian-omega: version bump to 1.4.17
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'app-text/xapian-omega')
-rw-r--r--app-text/xapian-omega/Manifest1
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.17.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/xapian-omega/Manifest b/app-text/xapian-omega/Manifest
index 5295bcfdafac..2a62c29bf1f3 100644
--- a/app-text/xapian-omega/Manifest
+++ b/app-text/xapian-omega/Manifest
@@ -2,3 +2,4 @@ DIST xapian-omega-1.2.25.tar.xz 440224 BLAKE2B 1e67cff0ed1796349df5da7d33c07febb
DIST xapian-omega-1.4.14.tar.xz 540532 BLAKE2B 193e03bfea5cf7cb5fc5bfca57f80b1390ba63ca999f235a10a7ab9bf4db378273cf6f7f6b3107c80c1ebb44bdb1a94ce3c00585f83ac0bec188163633be843b SHA512 27059d13bbdfc2ee9e8f4f6e74479bac0885cabab97d7eb1ebdc57eacbff1724b2684ba72efdf6d35f608e2e8f0891d47c626aaa100c713f4c2f66f923d841b7
DIST xapian-omega-1.4.15.tar.xz 545916 BLAKE2B be89c817d13888bc8de28973be15a512992dc1e6c23ea55f0470b179c9b29b82f2f2988c6ac430d62c3e45e6502555a3497bf3f3ce7bebf832fc8cf8e3dc9f1d SHA512 99ffe32c37b22db4557cae214a157d3b1bda27b2eb86f99862ca59ac326e5ba3f044fbd58a0ec9db7098700dd6a2422634c80987c9152536ec217e48d9694679
DIST xapian-omega-1.4.16.tar.xz 546360 BLAKE2B 990eab976833854d2a172e1584383b71375fe2e0b83a8ff0a150f4c9fdb6e99cbd42e58720e81698292843918112426d3b445efe14d9ee5f76e85304439475de SHA512 7f8c3d4e372c49f89e28da999ee49f0754052a339bbc4492b50f8134cf29b2c433ddae9e58ef3a2468898b711b4510ea87687a247ce21e83eba2f8daaa2910c4
+DIST xapian-omega-1.4.17.tar.xz 547372 BLAKE2B d164ee2f96d395e2a45919aea821d1bae9b028b64389b4a6e6f1179c0e1c2a92983a3fe7a71f68fe11e04eb61e9f011c21f2edf5660f9feedccd41de8ed2f445 SHA512 0388714ae307044b486e92eacac2d8c09c334e1b77be6cc2c36f8c0c679b4fee660c9b12074e9a278e2981b4a5b4a607d068a5d16c852bef719245bb70b7ce7c
diff --git a/app-text/xapian-omega/xapian-omega-1.4.17.ebuild b/app-text/xapian-omega/xapian-omega-1.4.17.ebuild
new file mode 100644
index 000000000000..f76f70d1acab
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+HOMEPAGE="https://xapian.org/"
+S="${WORKDIR}/xapian-omega-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/xapian:0/30
+ dev-lang/perl
+ dev-libs/libpcre
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${D}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}