summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2018-06-19 20:08:36 -0400
committerChris Reffett <creffett@gentoo.org>2018-06-19 21:21:22 -0400
commit5d2a203eac7c405960b8d5d13ed4b85abdc946d9 (patch)
tree6a4125ec6602b1eb8cc296db3a536a3de17db2ac /app-text/sword
parentapp-text/bibletime: Actually, bump to 2.11.2 (diff)
downloadgentoo-5d2a203eac7c405960b8d5d13ed4b85abdc946d9.tar.gz
gentoo-5d2a203eac7c405960b8d5d13ed4b85abdc946d9.tar.bz2
gentoo-5d2a203eac7c405960b8d5d13ed4b85abdc946d9.zip
app-text/sword: Version bump
Closes: https://bugs.gentoo.org/658358 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-text/sword')
-rw-r--r--app-text/sword/Manifest1
-rw-r--r--app-text/sword/sword-1.8.0.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/app-text/sword/Manifest b/app-text/sword/Manifest
index 1ea34213ec8a..739447b1e03e 100644
--- a/app-text/sword/Manifest
+++ b/app-text/sword/Manifest
@@ -1 +1,2 @@
DIST sword-1.7.4.tar.gz 2157882 BLAKE2B 7ed50430500ec428a125e24550a1f7d0437a0253cf4fabad4c8af452d2aa82c71c11e4a6c334ef1a95d82f14ce1cc092f3774210113e9668ba207875b3a11b20 SHA512 4c8b183e613367364439cc7a8a842012f75180fccc8eb775b9af2dc4c10f39c152261d35f0aadaaa91a11df36ab1a4057c2edc50ea4b0b3bb0ab0a847ff68f75
+DIST sword-1.8.0.tar.gz 2444386 BLAKE2B dd74ca409cdc3e4563ec5f0ed225556cfc3d1c89e63b41df8335b4abdd4f36b1423a2953a86105d2efe8d57c0e57065f74e74629309bab93f2a0222b9a8fcc86 SHA512 c45f3135255322a77e955297997db2529f31b397c42cc4b9474dc6ec8d329b2233b292078979de5fbf33cad4a1a607aabb66f86501072a729d68e9fc840c8c8e
diff --git a/app-text/sword/sword-1.8.0.ebuild b/app-text/sword/sword-1.8.0.ebuild
new file mode 100644
index 000000000000..bb6ed4a2b108
--- /dev/null
+++ b/app-text/sword/sword-1.8.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="Library for Bible reading software"
+HOMEPAGE="http://www.crosswire.org/sword/"
+SRC_URI="http://www.crosswire.org/ftpmirror/pub/${PN}/source/v${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~ppc-macos"
+IUSE="clucene curl debug doc icu static-libs"
+
+RDEPEND="sys-libs/zlib
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu:= )
+ clucene? ( dev-cpp/clucene )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS="AUTHORS CODINGSTYLE ChangeLog README"
+
+RESTRICT="test" #Restricting for now, see bug 313207
+
+src_prepare() {
+ sed -i \
+ -e '/FLAGS/s:-g3::' -e '/FLAGS/s:-O0::' \
+ -e '/FLAGS/s:-O2::' -e '/FLAGS/s:-O3::' \
+ configure || die
+
+ sed -i -e '/FLAGS/s:-Werror::' configure || die #408289
+ sed -i -e '/^#inc.*curl.*types/d' src/mgr/curl*.cpp || die #378055
+
+ cat <<-EOF > "${T}"/${PN}.conf
+ [Install]
+ DataPath=${EPREFIX}/usr/share/${PN}/
+ EOF
+ eapply "${FILESDIR}/${PN}-1.7.4-configure.patch"
+ eapply_user
+}
+
+src_configure() {
+ # TODO: Why is this here and can we remove it?
+ strip-flags
+
+ # bug 618776
+ append-cxxflags -std=c++14
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ --with-zlib \
+ $(use_with icu) \
+ --with-conf \
+ $(use_with curl) \
+ $(use_with clucene)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use doc; then
+ rm -rf examples/.cvsignore
+ rm -rf examples/cmdline/.cvsignore
+ rm -rf examples/cmdline/.deps
+ cp -R samples examples "${ED}"/usr/share/doc/${PF}/
+ fi
+
+ insinto /etc
+ doins "${T}"/${PN}.conf
+}
+
+pkg_postinst() {
+ elog "Check out http://www.crosswire.org/sword/modules/"
+ elog "to download modules that you would like to use with SWORD."
+ elog "Follow module installation instructions found on"
+ elog "the web or in ${EROOT}/usr/share/doc/${PF}/"
+}