summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-08-18 15:04:30 +0200
committerDavid Seifert <soap@gentoo.org>2019-08-18 15:06:00 +0200
commit7bae4800cb2b3a040db34a29b3f380786a8ffca5 (patch)
treee3933b0444d667719c2484c3904800ca2fa0956e /app-text/htmlinc
parentapp-i18n/kcc: Port to EAPI 7 (diff)
downloadgentoo-7bae4800cb2b3a040db34a29b3f380786a8ffca5.tar.gz
gentoo-7bae4800cb2b3a040db34a29b3f380786a8ffca5.tar.bz2
gentoo-7bae4800cb2b3a040db34a29b3f380786a8ffca5.zip
app-text/htmlinc: Port to EAPI 7
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text/htmlinc')
-rw-r--r--app-text/htmlinc/Manifest2
-rw-r--r--app-text/htmlinc/files/htmlinc-1.0_beta1-fix-build-system.patch33
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild31
3 files changed, 46 insertions, 20 deletions
diff --git a/app-text/htmlinc/Manifest b/app-text/htmlinc/Manifest
index 142fe80d71df..625afb5d3f71 100644
--- a/app-text/htmlinc/Manifest
+++ b/app-text/htmlinc/Manifest
@@ -1 +1 @@
-DIST htmlinc.tar.gz 17042 BLAKE2B 07c9333599876c17846dec8d40c0eba31f1f9321cfa463e4c5dd2698a120c878c6b2d0e6593eb78d22a15fa5333e0fb26ed064a9cccf6b95641cd9a7e3a13a53 SHA512 2bdb7a5df4a8152d9a23f7b740995bd565e92998ef199cfb7d08b1f5e8ae4390c5179f78da71dfa4b7ce18a2a0bfe6002d465b0fa8d860a25afdec5eb4f3ee4c
+DIST htmlinc-1.0_beta1.tar.gz 17042 BLAKE2B 07c9333599876c17846dec8d40c0eba31f1f9321cfa463e4c5dd2698a120c878c6b2d0e6593eb78d22a15fa5333e0fb26ed064a9cccf6b95641cd9a7e3a13a53 SHA512 2bdb7a5df4a8152d9a23f7b740995bd565e92998ef199cfb7d08b1f5e8ae4390c5179f78da71dfa4b7ce18a2a0bfe6002d465b0fa8d860a25afdec5eb4f3ee4c
diff --git a/app-text/htmlinc/files/htmlinc-1.0_beta1-fix-build-system.patch b/app-text/htmlinc/files/htmlinc-1.0_beta1-fix-build-system.patch
new file mode 100644
index 000000000000..3d0fff8d86f7
--- /dev/null
+++ b/app-text/htmlinc/files/htmlinc-1.0_beta1-fix-build-system.patch
@@ -0,0 +1,33 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,28 +1,9 @@
+-CC=g++
+-INSTDIR=/usr/local/bin
+-CFLAGS=-Wall
+-STRINGLIB=bytevector.o stringlist.o
+-
+-htmlinc :htmlinc.o
+- $(CC) $(STRINGLIB) htmlinc.o -o htmlinc $(CFLAGS)
+-
+-htmlinc.o: htmlinc.cc stringlist.o bytevector.o
+- $(CC) -c htmlinc.cc $(CFLAGS)
++htmlinc: bytevector.o stringlist.o
+
+ headers: text2h
+ text2h help <help.txt >help.h
+
+-text2h: text2h.o bytevector.o stringlist.o
+- $(CC) $(STRINGLIB) text2h.o -o text2h $(CFLAGS)
+-
+-text2h.o: text2h.cc
+- $(CC) -c text2h.cc $(CFLAGS)
+-
+-bytevector.o: bytevector.h bytevector.cc
+- ${CC} -c bytevector.cc $(CFLAGS)
+-
+-stringlist.o: bytevector.o stringlist.h stringlist.cc
+- $(CC) -c stringlist.cc $(CFLAGS)
++text2h: bytevector.o stringlist.o
+
+ clean:
+ rm *.o text2h htmlinc
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
index 694412759ced..a2d1afc50502 100644
--- a/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
+++ b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
@@ -1,37 +1,30 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="HTML Include System by Ulli Meybohm"
HOMEPAGE="http://www.meybohm.de/"
-SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
+SRC_URI="mirror://gentoo/${PN}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86 ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-S=${WORKDIR}/htmlinc
+S="${WORKDIR}/${PN}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-gcc3-gentoo.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
-src_prepare() {
- epatch "${FILESDIR}"/htmlinc-gcc3-gentoo.patch
- sed -i Makefile \
- -e 's| -o | $(LDFLAGS)&|g' \
- || die "sed Makefile"
-}
-
-src_compile() {
- # This is C++ not C source
- emake \
- CC=$(tc-getCXX) \
- CFLAGS="${CXXFLAGS} -Wall" \
- LDFLAGS="${LDFLAGS}"
+src_configure() {
+ tc-export CXX
+ append-cxxflags -Wall
}
src_install() {
dobin htmlinc
- dodoc README
+ einstalldocs
}