summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/enscript
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/enscript')
-rw-r--r--app-text/enscript/Manifest1
-rw-r--r--app-text/enscript/enscript-1.6.6.ebuild52
-rw-r--r--app-text/enscript/files/ebuild.st133
-rw-r--r--app-text/enscript/files/enscript-1.6.2-ruby.patch19
-rw-r--r--app-text/enscript/files/enscript-1.6.4-ebuild.st.patch10
-rw-r--r--app-text/enscript/files/enscript-1.6.5.2-php.st.patch11
-rw-r--r--app-text/enscript/files/ruby.st212
-rw-r--r--app-text/enscript/metadata.xml5
8 files changed, 443 insertions, 0 deletions
diff --git a/app-text/enscript/Manifest b/app-text/enscript/Manifest
new file mode 100644
index 000000000000..8d4585af1ed3
--- /dev/null
+++ b/app-text/enscript/Manifest
@@ -0,0 +1 @@
+DIST enscript-1.6.6.tar.gz 1330493 SHA256 6d56bada6934d055b34b6c90399aa85975e66457ac5bf513427ae7fc77f5c0bb SHA512 bf1c2b9ea7723518a1ef312145ddcd6ffdef0c6e8b5795ea84cb55d76fccc02f441d0c2dc6897e970368186e6a829ab74a090716624e0f7a8f575653fa495ebc WHIRLPOOL 718d06a76add39cc916a4a30262049787de73aee5e569407bf5a40eba4f90cd47c89ed6cc151269175d4fe250c15f6a04aed138828315988697d5b9eda03d055
diff --git a/app-text/enscript/enscript-1.6.6.ebuild b/app-text/enscript/enscript-1.6.6.ebuild
new file mode 100644
index 000000000000..bc88508ad6f4
--- /dev/null
+++ b/app-text/enscript/enscript-1.6.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="powerful text-to-postscript converter"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/enscript/enscript.html"
+
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-3"
+IUSE="nls ruby"
+
+DEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/enscript-1.6.4-ebuild.st.patch
+ epatch "${FILESDIR}"/enscript-1.6.5.2-php.st.patch
+ use ruby && epatch "${FILESDIR}"/enscript-1.6.2-ruby.patch
+ sed -i src/tests/passthrough.test -e 's|tail +2|tail -n +2|g' || die
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO || die "dodoc failed"
+
+ insinto /usr/share/enscript/hl
+ doins "${FILESDIR}"/ebuild.st || die "doins ebuild.st failed"
+
+ if use ruby ; then
+ insinto /usr/share/enscript/hl
+ doins "${FILESDIR}"/ruby.st || die "doins ruby.st failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "Now, customize /etc/enscript.cfg."
+}
diff --git a/app-text/enscript/files/ebuild.st b/app-text/enscript/files/ebuild.st
new file mode 100644
index 000000000000..d0eab41b5b8c
--- /dev/null
+++ b/app-text/enscript/files/ebuild.st
@@ -0,0 +1,133 @@
+/**
+ * Name: ebuild
+ * Description: Gentoo Portage ebuild
+ * Author: Ed Catmur <ed@catmur.co.uk>
+ *
+ * Based on gentoo.vim by Ciaran McCreesh <ciaranm@gentoo.org>
+ */
+
+state ebuild extends bash
+{
+ /* Variables */
+ /^([ \t]*)([0-9a-zA-Z_.-]+)(=)/ {
+ language_print ($1);
+ variable_name_face(true);
+ language_print ($2);
+ variable_name_face(false);
+ language_print ($3);
+ }
+
+ /* Core keywords */
+ /\b(use|has_version|best_version|use_with|use_enable|check_KV\
+|keepdir|econf|die|einstall|einfo|ewarn|eerror|diropts\
+|dobin|docinto|dodoc|doexe|dohard|dohtml|doinfo|doins\
+|dolib|dolib|a|dolib|so|doman|dosbin|dosym|emake|exeinto\
+|exeopts|fowners|fperms|insinto|insopts|into|libopts|newbin\
+|newexe|newins|newman|newsbin|prepall|prepalldocs|prepallinfo\
+|prepallman|prepallstrip|has|unpack|dopython|dosed|into\
+|doinitd|doconfd|doenvd|dojar|domo|dodir|ebegin|eend\
+|newconfd|newdoc|newenvd|newinitd|newlib\.a|newlib\.so\
+|hasq|hasv|useq|usev\
+|addread|addwrite|adddeny|addpredict\
+|inherit\
+|EXPORT_FUNCTIONS)\b/ {
+ keyword_face(true);
+ language_print ($0);
+ keyword_face (false);
+ }
+
+ /* Recognised functions */
+ /\b(pkg_nofetch|pkg_setup|src_unpack|src_compile|src_test|src_install\
+|pkg_preinst|pkg_postinst|pkg_prerm|pkg_postrm|pkg_config)\b/ {
+ function_name_face(true);
+ language_print ($0);
+ function_name_face(false);
+ }
+
+ /* Other keywords */
+ /\b(gen_usr_ldscript|draw_line|epatch|have_NPTL|get_number_of_jobs|egetent\
+|emktemp|enewuser|enewgroup|edos2unix|make_desktop_entry|unpack_pdv\
+|unpack_makeself|check_license|cdrom_get_cds|cdrom_load_next\
+|cdrom_locate_file_on_cd|strip|linguas|epause|ebeep|built_with_use\
+|make_session_desktop|domenu|doicon|find_unpackable_file|unpack_pdv\
+|set_arch_to_kernel|set_arch_to_portage|preserve_old_lib\
+|preserve_old_lib_notify|built_with_use|epunt_cxx|dopamd|newpamd\
+|make_wrapper\
+|setup-allowed-flags|filter-flags|filter-lfs-flags|append-lfs-flags\
+|append-flags|replace-flags|replace-cpu-flags|is-flag|filter-mfpmath\
+|strip-flags|test_flag|test_version_info|strip-unsupported-flags|get-flag\
+|has_hardened|has_pic|has_pie|has_ssp_all|has_ssp|has_m64|has_m32\
+|replace-sparc64-flags|append-ldflags|filter-ldflags|fstack-flags|gcc2-flags\
+|gcc-getCC|gcc-getCXX|gcc-fullversion|gcc-version|gcc-major-version\
+|gcc-minor-version|gcc-micro-version|gcc-libpath|gcc-libstdcxx-version\
+|gcc-libstdcxx-major-version|gcc2-flags\
+|elibtoolize|uclibctoolize|darwintoolize\
+|ht_fix_file|ht_fix_all\
+|fdo-mime_desktop_database_update|fdo-mime_mime_database_update\
+|webapp_checkfileexists|webapp_import_config|webapp_strip_appdir\
+|webapp_strip_d|webapp_strip_cwd|webapp_configfile|webapp_hook_script\
+|webapp_postinst_txt|webapp_postupgrade_txt|webapp_runbycgibin\
+|webapp_serverowned|webapp_server_configfile|webapp_sqlscript\
+|webapp_src_install|webapp_pkg_postinst|webapp_pkg_setup\
+|webapp_getinstalltype|webapp_src_preinst|webapp_pkg_prerm\
+|get_all_version_components|version_is_at_least\
+|get_version_components|get_major_version\
+|get_version_component_range|get_after_major_version\
+|replace_version_separator|replace_all_version_separators\
+|delete_version_separator|delete_all_version_separators\
+|cvs_fetch|cvs_src_unpack\
+|dobashcompletion|bash-completion_pkg_postinst\
+|vim-plugin_src_install|vim-plugin_pkg_postinst|vim-plugin_pkg_postrm\
+|update_vim_afterscripts|display_vim_plugin_help\
+|update_vim_helptags\
+|has_multilib_profile|get_libdir|get_multilibdir|get_libdir_override\
+|get_abi_var|get_abi_CFLAGS|get_abi_LDFLAGS|get_abi_CHOST\
+|get_abi_FAKE_TARGETS|get_abi_CDEFINE|get_abi_LIBDIR|get_install_abis\
+|get_all_abis|get_all_libdirs|is_final_abi|number_abis|get_ml_incdir\
+|prep_ml_includes|create_ml_includes|create_ml_includes-absolute\
+|create_ml_includes-tidy_path|create_ml_includes-listdirs\
+|create_ml_includes-makedestdirs|create_ml_includes-allfiles\
+|create_ml_includes-sym_for_dir\
+|64-bit\
+|tc-getPROG|tc-getAR|tc-getAS|tc-getCC|tc-getCXX|tc-getLD|tc-getNM\
+|tc-getRANLIB|tc-getF77|tc-getGCJ|tc-getBUILD_CC|tc-export|ninj\
+|tc-is-cross-compiler|tc-ninja_magic_to_arch|tc-arch-kernel|tc-arch\
+|tc-endian|gcc-fullversion|gcc-version|gcc-major-version\
+|gcc-minor-version|gcc-micro-version\
+|docrondir|docron|docrontab|cron_pkg_postinst\
+|egamesconf|egamesinstall|gameswrapper|dogamesbin|dogamessbin|dogameslib\
+|dogameslib.a|dogameslib.so|newgamesbin|newgamessbin|gamesowners|gamesperms\
+|prepgamesdirs|gamesenv|games_pkg_setup|games_src_compile|games_pkg_postinst\
+|games_ut_unpack|games_umod_unpack|games_make_wrapper\
+|subversion_svn_fetch|subversion_bootstrap|subversion_src_unpack\
+|alternatives_auto_makesym|alternatives_makesym|alternatives_pkg_postinst\
+|alternatives_pkg_postrm\
+|rpm_unpack|rpm_src_unpack\
+|python_version|python_tkinter_exists|python_mod_exists|python_mod_compile\
+|python_mod_optimize|python_mod_cleanup|python_disable_pyc\
+|python_enable_pyc\
+|check_version_h|get_KV_info|is_2_4_kernel|is_2_5_kernel|is_2_6_kernel\
+|kernel_supports_modules\
+|perl-module_src_prep|perl-module_src_compile|perl-module_src_test\
+|perl-module_src_install\
+|perl-module_pkg_postinst|perl-module_pkg_postrm\
+|perl_set_version|perl_delete_localpod|updatepod\
+|distutils_src_compile|distutils_src_install|distutils_pkg_postrm\
+|distutils_pkg_postinst|distutils_python_version|disutils_python_tkinter\
+|need_apache|need_apache1|need_apache2\
+|apache-module_pkg_setup|apache-module_src_compile\
+|apache-module_src_install|apache-module_pkg_postinst|acache_cd_dir\
+|apache_mod_file|apache_doc_magic|apache1_src_compile|apache1_src_install\
+|apache1_pkg_postinst|apache2_pkg_setup|apache2_src_compile\
+|apache1_src_install|apache2_pkg_postinst\
+|dopamd|newpamd|dopamsecurity|newpamsecurity|getpam_mod_dir\
+|dopammod|newpammod|pamd_mimic_system\
+|virtualmake|Xmake|Xemake|Xeconf\
+|gnome2_src_configure|gnome2_src_compile|gnome2_src_install\
+|gnome2_gconf_install|gnome2_gconf_uninstal|gnome2_omf_fix\
+|gnome2_scrollkeeper_update|gnome2_pkg_postinst|gnome2_pkg_postrm)\b/ {
+ builtin_face(true);
+ language_print ($0);
+ builtin_face(false);
+ }
+}
diff --git a/app-text/enscript/files/enscript-1.6.2-ruby.patch b/app-text/enscript/files/enscript-1.6.2-ruby.patch
new file mode 100644
index 000000000000..b492ca4f44f7
--- /dev/null
+++ b/app-text/enscript/files/enscript-1.6.2-ruby.patch
@@ -0,0 +1,19 @@
+--- states/hl/enscript.st.orig 2006-12-17 02:10:37.000000000 +0100
++++ states/hl/enscript.st 2006-12-17 02:10:13.000000000 +0100
+@@ -489,6 +489,7 @@
+ /\.idl$/ idl;
+ /\.(hs|lhs|gs|lgs)$/ haskell;
+ /\.(pm|pl)$/ perl;
++ /\.(rb|rbw)$/ ruby;
+ /\.(eps|EPS|ps|PS)$/ postscript;
+ /\.py$/ python;
+ /\.pyx$/ pyrex;
+@@ -531,6 +532,8 @@
+ /-\*- [Ii][Dd][Ll] -\*-/ idl;
+ /-\*- [Pp][Ee][Rr][Ll] -\*-/ perl;
+ /^#![ \t]*\/.*\/perl/ perl;
++ /-\*- [Rr][Uu][Bb][Yy] -\*-/ ruby;
++ /^#![ \t]*\/.*\/ruby/ ruby;
+ /^From:/ mail;
+ /^#![ \t]*(\/usr)?\/bin\/[ngmt]?awk/ awk;
+ /^#![ \t]*(\/usr)?\/bin\/sh/ sh;
diff --git a/app-text/enscript/files/enscript-1.6.4-ebuild.st.patch b/app-text/enscript/files/enscript-1.6.4-ebuild.st.patch
new file mode 100644
index 000000000000..0741576226af
--- /dev/null
+++ b/app-text/enscript/files/enscript-1.6.4-ebuild.st.patch
@@ -0,0 +1,10 @@
+--- states/hl/enscript.st 2006/01/31 05:37:23 1.1
++++ states/hl/enscript.st 2006/01/31 06:48:32
+@@ -509,6 +509,7 @@ namerules
+ /\b(rfc.*\.txt|draft-.*\.txt)$/ rfc;
+ /\.inf$/i inf;
+ /\.tex$/ tex;
++ /\.(ebuild|eclass)$/ ebuild;
+ /\.wmlscript$/ wmlscript;
+ /\.wmls$/ wmlscript;
+ /^.*$/ passthrough;
diff --git a/app-text/enscript/files/enscript-1.6.5.2-php.st.patch b/app-text/enscript/files/enscript-1.6.5.2-php.st.patch
new file mode 100644
index 000000000000..b146d998ee41
--- /dev/null
+++ b/app-text/enscript/files/enscript-1.6.5.2-php.st.patch
@@ -0,0 +1,11 @@
+diff -ruN enscript-1.6.5.2.orig/states/hl/enscript.st enscript-1.6.5.2/states/hl/enscript.st
+--- enscript-1.6.5.2.orig/states/hl/enscript.st 2010-06-02 00:17:49.000000000 +0200
++++ enscript-1.6.5.2/states/hl/enscript.st 2011-06-02 12:43:13.869855504 +0200
+@@ -510,6 +510,7 @@
+ /\.tex$/ tex;
+ /\.wmlscript$/ wmlscript;
+ /\.wmls$/ wmlscript;
++ /\.php$/ php;
+ /^.*$/ passthrough;
+ }
+
diff --git a/app-text/enscript/files/ruby.st b/app-text/enscript/files/ruby.st
new file mode 100644
index 000000000000..392c9c1390eb
--- /dev/null
+++ b/app-text/enscript/files/ruby.st
@@ -0,0 +1,212 @@
+/**
+ * Name: ruby
+ * Description: Ruby programming language.
+ * Author: Mike Wilson <m.v.wilson@home.com>
+ */
+
+state ruby_comment
+{
+ /\*\\\// {
+ language_print ($0);
+ return;
+ }
+ LANGUAGE_SPECIALS {
+ language_print ($0);
+ }
+}
+
+state ruby_dquot_string
+{
+ /\\\\./ {
+ language_print ($0);
+ }
+ /\"/ {
+ language_print ($0);
+ return;
+ }
+ LANGUAGE_SPECIALS {
+ language_print ($0);
+ }
+}
+
+state ruby_quot_string
+{
+ /\\\\./ {
+ language_print ($0);
+ }
+ /[\']/ {
+ language_print ($0);
+ return;
+ }
+ LANGUAGE_SPECIALS {
+ language_print ($0);
+ }
+}
+
+state ruby_bquot_string
+{
+ /\\\\./ {
+ language_print ($0);
+ }
+ /`/ {
+ language_print ($0);
+ return;
+ }
+ LANGUAGE_SPECIALS {
+ language_print ($0);
+ }
+}
+
+state ruby
+{
+ BEGIN {
+ header ();
+ }
+ END {
+ trailer ();
+ }
+
+ /* Comments. */
+ /#[^{].*$/ {
+ comment_face (true);
+ language_print ($0);
+ comment_face (false);
+ }
+
+ /* Ignore escaped quote marks */
+ /\\\"/ {
+ language_print ($0);
+ }
+ /\\\'/ {
+ language_print ($0);
+ }
+ /\\\`/ {
+ language_print ($0);
+ }
+
+ /* In cgi files, JavaScript might be imbedded, so we need to look out
+ * for the JavaScript comments, because they might contain something
+ * we don't like, like a contraction (don't, won't, etc.)
+ * We won't put them in comment face, because they are not ruby
+ * comments.
+ */
+ /\/\// {
+ language_print ($0);
+ call (eat_one_line);
+ }
+
+ /* String constants. */
+ /\"/ {
+ string_face (true);
+ language_print ($0);
+ call (ruby_dquot_string);
+ string_face (false);
+ }
+ /[\']/ {
+ string_face (true);
+ language_print ($0);
+ call (ruby_quot_string);
+ string_face (false);
+ }
+
+ /* Backquoted command string */
+ /`/ {
+ string_face (true);
+ language_print ($0);
+ call (ruby_bquot_string);
+ string_face (false);
+ }
+
+ /* Variables globals and instance */
+ /[$@]\w+/ {
+ variable_name_face (true);
+ language_print ($0);
+ variable_name_face (false);
+ }
+
+ /* Variables class variable */
+ /@@\w+/ {
+ variable_name_face (true);
+ language_print ($0);
+ variable_name_face (false);
+ }
+
+ /([ \t]*)(def)([ \t]+)([^(]*)/ {
+ /* indentation */
+ language_print ($1);
+
+ /* def */
+ keyword_face (true);
+ language_print ($2);
+ keyword_face (false);
+
+ /* middle */
+ language_print ($3);
+
+ /* Function name. */
+ function_name_face (true);
+ language_print ($4);
+ function_name_face (false);
+ }
+
+ /\$[!@&`'+~=\/\\,;.<>_*$?:"]/ {
+ variable_name_face (true);
+ language_print ($0);
+ variable_name_face (false);
+ }
+
+ /* Highlighting
+ --Type face
+ private protected public
+
+ --Builtin face (I consider these to be somewhat special)
+ alias alias_method attr attr_accessor attr_reader attr_writer
+ module_alias module_function self super
+
+ --Reference face
+ require include
+
+ --Keyword face
+ and begin break case class def defined? do else elsif end
+ ensure eval extend false for if in method module next nil not
+ or redo rescue retry return then true undef unless until when
+ while yield
+ */
+/\\b(private|protected|public)\\b/ {
+ type_face (true);
+ language_print ($0);
+ type_face (false);
+ }
+
+/\\b(alias|alias_method|attr|attr_accessor|attr_reader|attr_writer\\
+|module_alias|module_function|self|super)\\b/ {
+ builtin_face (true);
+ language_print ($0);
+ builtin_face (false);
+ }
+
+/\\b(include|require)\\b/ {
+ reference_face (true);
+ language_print ($0);
+ reference_face (false);
+ }
+
+/\\b(and|begin|break|case|class|def|defined?|do|else|elsif|end|ensure|eval\\
+|extend|false|for|if|in|method|module|next|nil|not|or|raise|redo|rescue|retry\\
+|return|then|true|undef|unless|until|when|while|yield)\\b/ {
+ keyword_face (true);
+ language_print ($0);
+ keyword_face (false);
+ }
+
+ LANGUAGE_SPECIALS {
+ language_print ($0);
+ }
+}
+
+
+/*
+Local variables:
+mode: c
+End:
+*/
diff --git a/app-text/enscript/metadata.xml b/app-text/enscript/metadata.xml
new file mode 100644
index 000000000000..1fa0ca569505
--- /dev/null
+++ b/app-text/enscript/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>printing</herd>
+</pkgmetadata>