summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-26 09:14:17 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-28 06:33:50 +1000
commit18bb06051851b05eda1f3ddca25913867a801388 (patch)
tree334bc24e4eec6e2dcd7ee5d1842b872999e02627 /app-text/doxygen
parentnet-misc/wget: Stabilize 1.25.0 hppa, #943879 (diff)
downloadgentoo-18bb06051851b05eda1f3ddca25913867a801388.tar.gz
gentoo-18bb06051851b05eda1f3ddca25913867a801388.tar.bz2
gentoo-18bb06051851b05eda1f3ddca25913867a801388.zip
app-text/doxygen: add LLVM_OPTIONAL; bump LLVM_COMPAT
This ebuild does not require the use of LLVM however it forces it as a dependency since the change to the llvm-r1 eclass. Add LLVM_OPTIONAL as there's already a `clang?` block in RDEPEND to pull in the appropriate slot, and set the appropriate REQUIRED_USE based on that. Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'app-text/doxygen')
-rw-r--r--app-text/doxygen/doxygen-1.12.0.ebuild5
-rw-r--r--app-text/doxygen/doxygen-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/app-text/doxygen/doxygen-1.12.0.ebuild b/app-text/doxygen/doxygen-1.12.0.ebuild
index d1fa2b98e60f..68fc4d9fd141 100644
--- a/app-text/doxygen/doxygen-1.12.0.ebuild
+++ b/app-text/doxygen/doxygen-1.12.0.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-LLVM_COMPAT=( 18 )
+LLVM_COMPAT=( 18 19 )
+LLVM_OPTIONAL=1
PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE="xml(+)"
@@ -29,7 +30,7 @@ IUSE="clang debug doc dot doxysearch gui test"
# - We keep the odd construct of noop USE=test because of
# the special relationship b/t RESTRICT & USE for tests.
# Also, it's a hint which avoids tests being silently skipped during arch testing.
-REQUIRED_USE="test? ( doc )"
+REQUIRED_USE="clang? ( ${LLVM_REQUIRED_USE} ) test? ( doc )"
RESTRICT="!test? ( test )"
BDEPEND="
diff --git a/app-text/doxygen/doxygen-9999.ebuild b/app-text/doxygen/doxygen-9999.ebuild
index 11574814a9e2..e68a8a4a1700 100644
--- a/app-text/doxygen/doxygen-9999.ebuild
+++ b/app-text/doxygen/doxygen-9999.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-LLVM_COMPAT=( 18 )
+LLVM_COMPAT=( 18 19 )
+LLVM_OPTIONAL=1
PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE="xml(+)"
@@ -29,7 +30,7 @@ IUSE="clang debug doc dot doxysearch gui test"
# - We keep the odd construct of noop USE=test because of
# the special relationship b/t RESTRICT & USE for tests.
# Also, it's a hint which avoids tests being silently skipped during arch testing.
-REQUIRED_USE="test? ( doc )"
+REQUIRED_USE="clang? ( ${LLVM_REQUIRED_USE} ) test? ( doc )"
RESTRICT="!test? ( test )"
BDEPEND="