summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-13 04:21:02 +0000
committerSam James <sam@gentoo.org>2023-02-13 04:21:02 +0000
commitb5c6e9e7cae8ca65e7751e942cbfe034672195c3 (patch)
tree9bdbaafae1eb9282560d0224186087c26e81f8de /app-text/dos2unix
parentnet-mail/cyrus-imapd: add 3.4.5 (diff)
downloadgentoo-b5c6e9e7cae8ca65e7751e942cbfe034672195c3.tar.gz
gentoo-b5c6e9e7cae8ca65e7751e942cbfe034672195c3.tar.bz2
gentoo-b5c6e9e7cae8ca65e7751e942cbfe034672195c3.zip
app-text/dos2unix: add 7.4.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/Manifest1
-rw-r--r--app-text/dos2unix/dos2unix-7.4.4.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-text/dos2unix/Manifest b/app-text/dos2unix/Manifest
index 6a9a84a03711..416a8a8c6ee1 100644
--- a/app-text/dos2unix/Manifest
+++ b/app-text/dos2unix/Manifest
@@ -1 +1,2 @@
DIST dos2unix-7.4.3.tar.gz 788278 BLAKE2B da959b06e583bbf27a2cb2ce5b1f1a41380722aa09ac75b3d31260e92fd6f1203d87266d3a12201b036a69796b4aa4f23718741036e20fe686801bb368fbde22 SHA512 1c6d81348de8aca451174794141d0802685487cf6847fa91f7de745d89bcf2af864fc2ec549b9af72031891d4efcb9731fe823ce05da36d1f9e9890ff2cb60fb
+DIST dos2unix-7.4.4.tar.gz 914647 BLAKE2B eb8d33344780bb15201eed571d7a6a21db0bc13e8e94388c70e1daea84cc0d1dfb9f16b7ed1cd216bb31ffd84dee706e7f2fb46050a299602f7c67c53915ded9 SHA512 e7a6b1d90bf0a32aa53b22caa1660dcf58c5874d02a45e80f4cc811cae9bd7b0cb8144301fb6808798100a057c03210925da1d8461e380dff1059f6bee086f55
diff --git a/app-text/dos2unix/dos2unix-7.4.4.ebuild b/app-text/dos2unix/dos2unix-7.4.4.ebuild
new file mode 100644
index 000000000000..5c0b6d2870e4
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-7.4.4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="ca da de eo es fr fur hu ja ka ko nb nl pl pt_BR ro ru sr sv uk vi zh_CN zh_TW"
+
+inherit plocale toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="https://www.xs4all.nl/~waterlan/dos2unix.html https://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ https://www.xs4all.nl/~waterlan/${PN}/${P/_/-}.tar.gz
+ mirror://sourceforge/${PN}/${P/_/-}.tar.gz
+"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="BSD-2"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls test"
+
+RDEPEND="
+ !app-text/hd2u
+ virtual/libintl"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( virtual/perl-Test-Simple )
+"
+BDEPEND="
+ dev-lang/perl
+ nls? ( sys-devel/gettext )
+"
+
+RESTRICT="!test? ( test )"
+
+handle_locales() {
+ # Make sure locale list is kept up-to-date.
+ local detected sorted
+ detected=$(echo $(printf '%s\n' */*.po | sed -e 's:.*/::' -e 's:.po$::' | sort -u))
+ sorted=$(echo $(printf '%s\n' ${PLOCALES} | sort -u))
+ if [[ ${sorted} != "${detected}" ]] ; then
+ eerror "The ebuild needs to be kept in sync."
+ eerror "PLOCALES: ${sorted}"
+ eerror "po*/*.po: ${detected}"
+ die "sync PLOCALES"
+ fi
+
+ # Deal with selective install of locales.
+ rm_loc() { rm po*/$1.po || die; }
+ plocale_for_each_disabled_locale rm_loc
+}
+
+src_prepare() {
+ default
+
+ handle_locales
+
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_musl && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(usex nls "LDFLAGS_EXTRA=$(lintl)" "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(usex nls "" "ENABLE_NLS=") install
+}