summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-01 12:09:10 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-01 13:36:24 +0200
commitec821e92460679181bf2d63a8f899f0b8fbf7e24 (patch)
treeb8355bbc9af1032f45d29d3e9f071b5b6b6bafb5 /app-portage
parentmedia-radio/fldigi: Fix DEPS, honour CPU_FLAGS_X86 settings (diff)
downloadgentoo-ec821e92460679181bf2d63a8f899f0b8fbf7e24.tar.gz
gentoo-ec821e92460679181bf2d63a8f899f0b8fbf7e24.tar.bz2
gentoo-ec821e92460679181bf2d63a8f899f0b8fbf7e24.zip
app-portage/gemato: Add a live ebuild for multiprocessing branch
Add a separate ebuild for multiprocessing branch and keep it p.masked due to the known hangs. Hopefully it will help testing and finding a proper solution to that. Bug: https://bugs.gentoo.org/647964
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/gemato-9999m.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-portage/gemato/gemato-9999m.ebuild b/app-portage/gemato/gemato-9999m.ebuild
new file mode 100644
index 000000000000..57616701daf2
--- /dev/null
+++ b/app-portage/gemato/gemato-9999m.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
+PYTHON_REQ_USE='threads(+)'
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/mgorny/gemato.git"
+EGIT_BRANCH="multiprocessing"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+blake2 bzip2 +gpg lzma sha3 test tools"
+
+MODULE_RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+
+RDEPEND="${MODULE_RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND=">=dev-python/setuptools-34[${PYTHON_USEDEP}]
+ test? ( ${MODULE_RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}
+
+pkg_postinst() {
+ elog "The multiprocessing support in gemato may cause the process to hang."
+ elog "Please see https://bugs.gentoo.org/647964 for more details."
+}