summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-03-06 13:25:18 -0800
committerZac Medico <zmedico@gentoo.org>2024-03-06 13:38:15 -0800
commitdfd4113c6373f7996ea8a7c7526a15ba92cae1ef (patch)
tree524fb6f765f11f00b5eb16a13da4a9533a1844b6 /app-portage
parentdev-lang/go-bootstrap: move make-go-bootstraps script to this package (diff)
downloadgentoo-dfd4113c6373f7996ea8a7c7526a15ba92cae1ef.tar.gz
gentoo-dfd4113c6373f7996ea8a7c7526a15ba92cae1ef.tar.bz2
gentoo-dfd4113c6373f7996ea8a7c7526a15ba92cae1ef.zip
app-portage/mirrorselect: enable PEP517 build
Closes: https://bugs.gentoo.org/841131 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/mirrorselect/mirrorselect-2.4.0.ebuild7
-rw-r--r--app-portage/mirrorselect/mirrorselect-9999.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/app-portage/mirrorselect/mirrorselect-2.4.0.ebuild b/app-portage/mirrorselect/mirrorselect-2.4.0.ebuild
index dfd5e8b06d24..c4998fc017db 100644
--- a/app-portage/mirrorselect/mirrorselect-2.4.0.ebuild
+++ b/app-portage/mirrorselect/mirrorselect-2.4.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="xml(+)"
@@ -33,6 +33,7 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="ipv6"
+BDEPEND="${DISTUTILS_DEPS}"
RDEPEND="
dev-util/dialog
>=net-analyzer/netselect-0.4[ipv6(+)?]
@@ -45,6 +46,8 @@ python_prepare_all() {
python_setup
local -x VERSION="${PVR}"
+ sed -e 's:os.path.join(os.sep, EPREFIX.lstrip(os.sep), "usr/share/man/man8"):"share/man/man8":' \
+ -i setup.py || die
eprefixify setup.py mirrorselect/main.py
edo "${PYTHON}" setup.py set_version
diff --git a/app-portage/mirrorselect/mirrorselect-9999.ebuild b/app-portage/mirrorselect/mirrorselect-9999.ebuild
index 7bfb3b6cf4ec..7d03c0ba1219 100644
--- a/app-portage/mirrorselect/mirrorselect-9999.ebuild
+++ b/app-portage/mirrorselect/mirrorselect-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="xml(+)"
@@ -33,6 +33,7 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="ipv6"
+BDEPEND="${DISTUTILS_DEPS}"
RDEPEND="
dev-util/dialog
>=net-analyzer/netselect-0.4[ipv6(+)?]
@@ -45,6 +46,8 @@ python_prepare_all() {
python_setup
local -x VERSION="${PVR}"
+ sed -e 's:os.path.join(os.sep, EPREFIX.lstrip(os.sep), "usr/share/man/man8"):"share/man/man8":' \
+ -i setup.py || die
eprefixify setup.py mirrorselect/main.py
edo "${PYTHON}" setup.py set_version