summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2022-07-10 13:52:57 -0700
committerBrian Dolbec <dolsen@gentoo.org>2022-07-10 14:19:12 -0700
commit98494dea065dd498addba76b72c3bdfb1c8aa53f (patch)
treeddfa9f3477a4a4ade8b2542001b3142671d6cc03 /app-portage
parentapp-containers/buildah: add 1.26.2 (diff)
downloadgentoo-98494dea065dd498addba76b72c3bdfb1c8aa53f.tar.gz
gentoo-98494dea065dd498addba76b72c3bdfb1c8aa53f.tar.bz2
gentoo-98494dea065dd498addba76b72c3bdfb1c8aa53f.zip
app-portage/gentoolkit: Bump to 0.6.1-r1, update 9999
Revert setuptools use due to incorrect data_files location Go back tio using distutils for now. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/files/gentoolkit-0.6.1-data_files.patch47
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.6.1-r1.ebuild (renamed from app-portage/gentoolkit/gentoolkit-0.6.1.ebuild)6
-rw-r--r--app-portage/gentoolkit/gentoolkit-9999.ebuild2
3 files changed, 53 insertions, 2 deletions
diff --git a/app-portage/gentoolkit/files/gentoolkit-0.6.1-data_files.patch b/app-portage/gentoolkit/files/gentoolkit-0.6.1-data_files.patch
new file mode 100644
index 000000000000..8039864d69f9
--- /dev/null
+++ b/app-portage/gentoolkit/files/gentoolkit-0.6.1-data_files.patch
@@ -0,0 +1,47 @@
+From 5b52ee6c6efab68111d128d45f386ac21eaf84f6 Mon Sep 17 00:00:00 2001
+From: Brian Dolbec <dolsen@gentoo.org>
+Date: Sun, 10 Jul 2022 13:41:36 -0700
+Subject: [PATCH] Revert "setup.py: migrate to setuptools"
+
+This reverts commit bbbde97b5e625a49a1a66e307931548cb33f260b.
+setuptools only installs data files to the python pkg directory
+---
+ setup.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 36995de..23e9b36 100755
+--- a/setup.py
++++ b/setup.py
+@@ -3,8 +3,8 @@
+ import re
+ import sys
+ import subprocess
+-
+-from setuptools import setup, Command
++from distutils import core
++from distutils.cmd import Command
+ from glob import glob
+
+ import os
+@@ -67,7 +67,7 @@ manpages = [
+ ]
+
+
+-class set_version(Command):
++class set_version(core.Command):
+ """Set python __version__ and bash VERSION to our __version__."""
+
+ description = "hardcode scripts' version using VERSION from environment"
+@@ -130,7 +130,7 @@ test_data = {
+ ]
+ }
+
+-setup(
++core.setup(
+ name="gentoolkit",
+ version=__version__,
+ description="Set of tools that work with and enhance portage.",
+--
+libgit2 1.4.3
+
diff --git a/app-portage/gentoolkit/gentoolkit-0.6.1.ebuild b/app-portage/gentoolkit/gentoolkit-0.6.1-r1.ebuild
index c9406219f5e3..d176540989f7 100644
--- a/app-portage/gentoolkit/gentoolkit-0.6.1.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-0.6.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="xml(+),threads(+)"
@@ -29,6 +29,10 @@ RDEPEND="${DEPEND}
virtual/awk
sys-apps/gentoo-functions"
+PATCHES=(
+ "${FILESDIR}/gentoolkit-0.6.1-data_files.patch"
+)
+
distutils_enable_tests setup.py
python_prepare_all() {
diff --git a/app-portage/gentoolkit/gentoolkit-9999.ebuild b/app-portage/gentoolkit/gentoolkit-9999.ebuild
index d030b9327a92..00ccd192438d 100644
--- a/app-portage/gentoolkit/gentoolkit-9999.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="xml(+),threads(+)"