summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-08-05 12:26:44 -0700
committerZac Medico <zmedico@gentoo.org>2018-08-05 12:40:01 -0700
commit2fa32bf30ba7747bb8ca5fe7f4032aed8248af0e (patch)
treecfceeaf9cfce60f3dd9925449d51cedeb3fd3a68 /app-portage
parentapp-portage/repoman: use elog instead of einfo for messages to users (diff)
downloadgentoo-2fa32bf30ba7747bb8ca5fe7f4032aed8248af0e.tar.gz
gentoo-2fa32bf30ba7747bb8ca5fe7f4032aed8248af0e.tar.bz2
gentoo-2fa32bf30ba7747bb8ca5fe7f4032aed8248af0e.zip
app-portage/repoman: pkg_postinst REPLACING_VERSIONS
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/repoman/repoman-2.3.10.ebuild20
-rw-r--r--app-portage/repoman/repoman-2.3.9.ebuild20
-rw-r--r--app-portage/repoman/repoman-9999.ebuild20
3 files changed, 33 insertions, 27 deletions
diff --git a/app-portage/repoman/repoman-2.3.10.ebuild b/app-portage/repoman/repoman-2.3.10.ebuild
index 24786452de2c..e071382f3c3a 100644
--- a/app-portage/repoman/repoman-2.3.10.ebuild
+++ b/app-portage/repoman/repoman-2.3.10.ebuild
@@ -49,13 +49,15 @@ python_install() {
}
pkg_postinst() {
- elog ""
- elog "This release of repoman is from the new portage/repoman split"
- elog "release code base."
- elog "This new repoman code base is still being developed. So its API's"
- elog "are not to be considered stable and are subject to change."
- elog "The code released has been tested and considered ready for use."
- elog "This however does not guarantee it to be completely bug free."
- elog "Please report any bugs you may encounter."
- elog ""
+ if [[ -z {REPLACING_VERSIONS} ]]; then
+ elog ""
+ elog "This release of repoman is from the new portage/repoman split"
+ elog "release code base."
+ elog "This new repoman code base is still being developed. So its API's"
+ elog "are not to be considered stable and are subject to change."
+ elog "The code released has been tested and considered ready for use."
+ elog "This however does not guarantee it to be completely bug free."
+ elog "Please report any bugs you may encounter."
+ elog ""
+ fi
}
diff --git a/app-portage/repoman/repoman-2.3.9.ebuild b/app-portage/repoman/repoman-2.3.9.ebuild
index c96092fb4866..c6113c7c5f07 100644
--- a/app-portage/repoman/repoman-2.3.9.ebuild
+++ b/app-portage/repoman/repoman-2.3.9.ebuild
@@ -55,13 +55,15 @@ python_install() {
}
pkg_postinst() {
- elog ""
- elog "This release of repoman is from the new portage/repoman split"
- elog "release code base."
- elog "This new repoman code base is still being developed. So its API's"
- elog "are not to be considered stable and are subject to change."
- elog "The code released has been tested and considered ready for use."
- elog "This however does not guarantee it to be completely bug free."
- elog "Please report any bugs you may encounter."
- elog ""
+ if [[ -z {REPLACING_VERSIONS} ]]; then
+ elog ""
+ elog "This release of repoman is from the new portage/repoman split"
+ elog "release code base."
+ elog "This new repoman code base is still being developed. So its API's"
+ elog "are not to be considered stable and are subject to change."
+ elog "The code released has been tested and considered ready for use."
+ elog "This however does not guarantee it to be completely bug free."
+ elog "Please report any bugs you may encounter."
+ elog ""
+ fi
}
diff --git a/app-portage/repoman/repoman-9999.ebuild b/app-portage/repoman/repoman-9999.ebuild
index a0770535b52c..8063252c048e 100644
--- a/app-portage/repoman/repoman-9999.ebuild
+++ b/app-portage/repoman/repoman-9999.ebuild
@@ -49,13 +49,15 @@ python_install() {
}
pkg_postinst() {
- elog ""
- elog "This release of repoman is from the new portage/repoman split"
- elog "release code base."
- elog "This new repoman code base is still being developed. So its API's"
- elog "are not to be considered stable and are subject to change."
- elog "The code released has been tested and considered ready for use."
- elog "This however does not guarantee it to be completely bug free."
- elog "Please report any bugs you may encounter."
- elog ""
+ if [[ -z {REPLACING_VERSIONS} ]]; then
+ elog ""
+ elog "This release of repoman is from the new portage/repoman split"
+ elog "release code base."
+ elog "This new repoman code base is still being developed. So its API's"
+ elog "are not to be considered stable and are subject to change."
+ elog "The code released has been tested and considered ready for use."
+ elog "This however does not guarantee it to be completely bug free."
+ elog "Please report any bugs you may encounter."
+ elog ""
+ fi
}