summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-16 01:44:42 +0100
committerSam James <sam@gentoo.org>2023-05-16 02:52:15 +0100
commit20daeb992dfaa00e2793b5f9d5e670e382b1db1a (patch)
treee7a708bd7696bf479b1c931f718a65f07e1b18cf /app-office
parentdev-lang/ruby: add Valgrind annotation support (diff)
downloadgentoo-20daeb992dfaa00e2793b5f9d5e670e382b1db1a.tar.gz
gentoo-20daeb992dfaa00e2793b5f9d5e670e382b1db1a.tar.bz2
gentoo-20daeb992dfaa00e2793b5f9d5e670e382b1db1a.zip
app-office/libreoffice: add Valgrind annotation support
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/libreoffice-7.5.3.2.ebuild4
-rw-r--r--app-office/libreoffice/libreoffice-7.5.9999.ebuild4
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild4
3 files changed, 9 insertions, 3 deletions
diff --git a/app-office/libreoffice/libreoffice-7.5.3.2.ebuild b/app-office/libreoffice/libreoffice-7.5.3.2.ebuild
index 941b2c21607a..772e63c73d8e 100644
--- a/app-office/libreoffice/libreoffice-7.5.3.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.5.3.2.ebuild
@@ -84,7 +84,7 @@ unset ADDONS_SRC
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
IUSE="accessibility base bluetooth +branding clang coinmp +cups custom-cflags +dbus debug eds firebird
-googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test vulkan
+googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test valgrind vulkan
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -243,6 +243,7 @@ DEPEND="${COMMON_DEPEND}
media-fonts/dejavu
media-fonts/liberation-fonts
)
+ valgrind? ( dev-util/valgrind )
"
RDEPEND="${COMMON_DEPEND}
acct-group/libreoffice
@@ -534,6 +535,7 @@ src_configure() {
$(use_with googledrive gdrive-client-secret ${google_default_client_secret})
$(use_with java)
$(use_with odk doxygen)
+ $(use_with valgrind)
)
if use eds || use gtk; then
diff --git a/app-office/libreoffice/libreoffice-7.5.9999.ebuild b/app-office/libreoffice/libreoffice-7.5.9999.ebuild
index 941b2c21607a..772e63c73d8e 100644
--- a/app-office/libreoffice/libreoffice-7.5.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-7.5.9999.ebuild
@@ -84,7 +84,7 @@ unset ADDONS_SRC
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
IUSE="accessibility base bluetooth +branding clang coinmp +cups custom-cflags +dbus debug eds firebird
-googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test vulkan
+googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test valgrind vulkan
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -243,6 +243,7 @@ DEPEND="${COMMON_DEPEND}
media-fonts/dejavu
media-fonts/liberation-fonts
)
+ valgrind? ( dev-util/valgrind )
"
RDEPEND="${COMMON_DEPEND}
acct-group/libreoffice
@@ -534,6 +535,7 @@ src_configure() {
$(use_with googledrive gdrive-client-secret ${google_default_client_secret})
$(use_with java)
$(use_with odk doxygen)
+ $(use_with valgrind)
)
if use eds || use gtk; then
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 3f227c0a320f..3e79b6523909 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -83,7 +83,7 @@ unset ADDONS_SRC
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
IUSE="accessibility base bluetooth +branding clang coinmp +cups custom-cflags +dbus debug eds firebird
-googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test vulkan
+googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test valgrind vulkan
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -242,6 +242,7 @@ DEPEND="${COMMON_DEPEND}
media-fonts/dejavu
media-fonts/liberation-fonts
)
+ valgrind? ( dev-util/valgrind )
"
RDEPEND="${COMMON_DEPEND}
acct-group/libreoffice
@@ -530,6 +531,7 @@ src_configure() {
$(use_with googledrive gdrive-client-secret ${google_default_client_secret})
$(use_with java)
$(use_with odk doxygen)
+ $(use_with valgrind)
)
if use eds || use gtk; then