summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-21 15:19:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-03-21 21:52:05 +0100
commit371eb8a1679d3e33e57a6d7860d2cbe734875bf2 (patch)
tree0230fdaedb3df6ae42bc96767e8a3c638b209d21 /app-office/calligra
parentwww-client/firefox: re-add fix_hardened_pie_detection to 52.x patchset (diff)
downloadgentoo-371eb8a1679d3e33e57a6d7860d2cbe734875bf2.tar.gz
gentoo-371eb8a1679d3e33e57a6d7860d2cbe734875bf2.tar.bz2
gentoo-371eb8a1679d3e33e57a6d7860d2cbe734875bf2.zip
app-office/calligra: Fix >=libwps-0.4 detection
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-office/calligra')
-rw-r--r--app-office/calligra/calligra-2.9.11-r1.ebuild1
-rw-r--r--app-office/calligra/files/calligra-2.9.11-libwps-0.4.patch46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-office/calligra/calligra-2.9.11-r1.ebuild b/app-office/calligra/calligra-2.9.11-r1.ebuild
index a28e2a28e240..a67a0fe9ec1d 100644
--- a/app-office/calligra/calligra-2.9.11-r1.ebuild
+++ b/app-office/calligra/calligra-2.9.11-r1.ebuild
@@ -141,6 +141,7 @@ RESTRICT=test
PATCHES=(
"${FILESDIR}"/${PN}-2.9.1-no-arch-detection.patch
"${FILESDIR}"/${P}-postgresql-9.6.patch
+ "${FILESDIR}"/${P}-libwps-0.4.patch
)
pkg_pretend() {
diff --git a/app-office/calligra/files/calligra-2.9.11-libwps-0.4.patch b/app-office/calligra/files/calligra-2.9.11-libwps-0.4.patch
new file mode 100644
index 000000000000..79595d9f883e
--- /dev/null
+++ b/app-office/calligra/files/calligra-2.9.11-libwps-0.4.patch
@@ -0,0 +1,46 @@
+Last-Update: 2015-06-17
+Forwarded: no
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=788969
+Origin: http://pkgs.fedoraproject.org/cgit/calligra.git/commit/?id=124c28df44584e08b00d4dbb859362af73c41070
+From: David Tardon <dtardon@redhat.com>
+Description: adapt to libwps 0.4
+
+--- a/cmake/modules/FindLibWps.cmake
++++ b/cmake/modules/FindLibWps.cmake
+@@ -9,18 +9,18 @@
+ # Redistribution and use is allowed according to the terms of the BSD license.
+
+ include(LibFindMacros)
+ libfind_package(LIBWPS LibWpd)
+-libfind_pkg_check_modules(LIBWPS_PKGCONF libwps-0.3)
++libfind_pkg_check_modules(LIBWPS_PKGCONF libwps-0.4)
+
+ find_path(LIBWPS_INCLUDE_DIR
+ NAMES libwps/libwps.h
+ HINTS ${LIBWPS_PKGCONF_INCLUDE_DIRS} ${LIBWPS_PKGCONF_INCLUDEDIR}
+- PATH_SUFFIXES libwps-0.3
++ PATH_SUFFIXES libwps-0.4
+ )
+
+ find_library(LIBWPS_LIBRARY
+- NAMES wps wps-0.3
++ NAMES wps wps-0.4
+ HINTS ${LIBWPS_PKGCONF_LIBRARY_DIRS} ${LIBWPS_PKGCONF_LIBDIR}
+ )
+
+ set(LIBWPS_PROCESS_LIBS LIBWPS_LIBRARY LIBWPD_LIBRARIES)
+--- a/filters/words/works/import/WPSImport.cpp
++++ b/filters/words/works/import/WPSImport.cpp
+@@ -90,9 +90,11 @@
+ }
+ bool isSupportedFormat(librevenge::RVNGInputStream &input)
+ {
+ WPSKind kind = WPS_TEXT;
+- WPSConfidence confidence = WPSDocument::isFileFormatSupported(&input, kind);
++ WPSCreator creator = WPS_MSWORKS;
++ bool needsEncoding = false;
++ WPSConfidence confidence = WPSDocument::isFileFormatSupported(&input, kind, creator, needsEncoding);
+ if (confidence == WPS_CONFIDENCE_NONE || kind != WPS_TEXT)
+ return false;
+ return true;
+ }