summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Genasci <fedeliallalinea@gmail.com>2023-07-19 20:21:43 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-07-28 22:09:36 +0200
commitc97b976202b3101266b1d2efe0dfc99fd722ad2b (patch)
treed386e07b6629ddef500c3251d5097bf3331ce2f4 /app-mobilephone
parentx11-plugins/wmmp3: Fix implicit declaration of function malloc (diff)
downloadgentoo-c97b976202b3101266b1d2efe0dfc99fd722ad2b.tar.gz
gentoo-c97b976202b3101266b1d2efe0dfc99fd722ad2b.tar.bz2
gentoo-c97b976202b3101266b1d2efe0dfc99fd722ad2b.zip
app-mobilephone/scrcpy: version bump to 2.1.1
Signed-off-by: Marco Genasci <fedeliallalinea@gmail.com> Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/scrcpy/Manifest2
-rw-r--r--app-mobilephone/scrcpy/metadata.xml1
-rw-r--r--app-mobilephone/scrcpy/scrcpy-2.1.1.ebuild42
3 files changed, 44 insertions, 1 deletions
diff --git a/app-mobilephone/scrcpy/Manifest b/app-mobilephone/scrcpy/Manifest
index dc048a228705..0d9c63bb42d6 100644
--- a/app-mobilephone/scrcpy/Manifest
+++ b/app-mobilephone/scrcpy/Manifest
@@ -1,4 +1,6 @@
DIST scrcpy-2.0.tar.gz 375902 BLAKE2B b45a0191a4b634a6fd165a870ce925968eb2bf697eedd88744abf6e6282afa8a4c2108e85e6d479be47e6ddc08a8b5a54875315d1319721639fea8b49f423817 SHA512 c7f6a20ff470c529f3d9a211ee02eebc028f698b2215665c8386afda8db4ea51206bb3c3182d846485399101f0add35844477ebd37df30724cb43c3882c6dc4d
+DIST scrcpy-2.1.1.tar.gz 386002 BLAKE2B 3d1ec3829cc08d36a6b42f7429749000ea5a4aaf2b8501167fe03b68fb722ec9351da9f287aef752fbceebf04db1484071c4fdf3b84bc5d9eb3805f635502951 SHA512 247d2b4d5523412c667b3104621cdbb5d4a47f1fbc34e4fbde242212d9a4a198232d886eb5d4dc8678fbbe97a63d747827986fd34b08b0951bce02f256e65c47
DIST scrcpy-2.1.tar.gz 385830 BLAKE2B 2889f263325e9274c5b68fd2081f9a2093faf8e6bd3fec3cdf941ad25df88f0a73183e9225d69098d5d05455146e6e7e126211cf5e94d4df3ab1f68553ebe32a SHA512 bb0bf7d975beef1d30269485a070193226ae6527821fe6128d45f917353d4a7b52d0736ae462ea9fa52be744a8257753225fd8f99a15c2f88e15cbfc4c36c646
DIST scrcpy-server-v2.0 52867 BLAKE2B 6867677059ed60358e8d4f62a01d09d177a52a3ad5d9faf29017666b4566052c9be1777b75df24989d49acf640ff10071daddf760990f18c1df07e1f70c772ff SHA512 366e594ee87101635050185759eb03982b8749f1efe5c8f02d0fb5f60edfdacbd8280a183b872b1484648d2556cbde5abbaf1f3fd92a7f6f604181b9e81ffcde
DIST scrcpy-server-v2.1 56955 BLAKE2B d3f993fb39549ce2bdcf9dda6c9f6bbc57c1367236734990d5aa193eb6a99b1170b111cf0c0debcd4c8981144bbb86437a2ace355011c54996c2c60325bbea6d SHA512 4cf9a49f8f3cba1bab0bd8ad53773ebff6f89b291bfe808251e979270e43f24b79cf8cc8eaece94487c44410ebd28a546a70e9d8f8455df9cdb90b11f83714aa
+DIST scrcpy-server-v2.1.1 56995 BLAKE2B 6a089ca33025873f48d62389b17ba6fb6249c007ef7d7fd21883351e7724c3207dce1cea8b655cb949361d26210f5bb6115a2f5f9895c8a3b129652a77848c3d SHA512 f9b27068a92042e6d05ca4d56e6220174fbb008d21c2c423ad3adf91ac1ba0d30cf63a2d9072608adee56f5b49e5a55f9a193737ddf80fb222b447af196c4a90
diff --git a/app-mobilephone/scrcpy/metadata.xml b/app-mobilephone/scrcpy/metadata.xml
index fbaf39bf41c5..6d3156f41a83 100644
--- a/app-mobilephone/scrcpy/metadata.xml
+++ b/app-mobilephone/scrcpy/metadata.xml
@@ -7,7 +7,6 @@
</maintainer>
<use>
<flag name="lto">Build with Link Time Optimization (LTO)</flag>
- <flag name="pipewire">Enable support for the <pkg>media-video/pipewire</pkg> audio backend</flag>
</use>
<upstream>
<remote-id type="github">Genymobile/scrcpy</remote-id>
diff --git a/app-mobilephone/scrcpy/scrcpy-2.1.1.ebuild b/app-mobilephone/scrcpy/scrcpy-2.1.1.ebuild
new file mode 100644
index 000000000000..a24a7aa758ab
--- /dev/null
+++ b/app-mobilephone/scrcpy/scrcpy-2.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Display and control your Android device"
+HOMEPAGE="https://github.com/Genymobile/scrcpy"
+# Source code and server part on Android device
+SRC_URI="https://github.com/Genymobile/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Genymobile/${PN}/releases/download/v${PV}/${PN}-server-v${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="lto"
+
+DEPEND="media-libs/libsdl2[X]
+ media-video/ffmpeg
+ virtual/libusb:1"
+# Manual install for ppc64 until bug #723528 is fixed
+RDEPEND="${DEPEND}
+ !ppc64? ( dev-util/android-tools )"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use lto b_lto)
+ -Dprebuilt_server="${DISTDIR}/${PN}-server-v${PV}"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+
+ einfo "If you use pipewire because of a problem with libsdl2 it is possible that"
+ einfo "scrcpy will not start, in which case start the program by exporting the"
+ einfo "environment variable SDL_AUDIODRIVER=pipewire."
+ einfo "For more information see https://github.com/Genymobile/scrcpy/issues/3864."
+}