summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-13 21:48:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-13 21:50:41 +0300
commitc02d58e6a1274f60e24ff437c3bcbb08c3927507 (patch)
tree6884aa7b9bb5299fd9c8d89a7b7c0c109c47b6b8 /app-mobilephone
parentapp-mobilephone/gnokii: EAPI 6 -> 8 (diff)
downloadgentoo-c02d58e6a1274f60e24ff437c3bcbb08c3927507.tar.gz
gentoo-c02d58e6a1274f60e24ff437c3bcbb08c3927507.tar.bz2
gentoo-c02d58e6a1274f60e24ff437c3bcbb08c3927507.zip
app-mobilephone/gnokii: drop 9999
Last upstream change in git is from 2011. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gnokii/files/gnokii-9999-icon.patch11
-rw-r--r--app-mobilephone/gnokii/files/gnokii-9999-translations.patch10
-rw-r--r--app-mobilephone/gnokii/gnokii-0.6.31-r5.ebuild24
-rw-r--r--app-mobilephone/gnokii/gnokii-9999.ebuild135
4 files changed, 2 insertions, 178 deletions
diff --git a/app-mobilephone/gnokii/files/gnokii-9999-icon.patch b/app-mobilephone/gnokii/files/gnokii-9999-icon.patch
deleted file mode 100644
index 13ca2cf6e4ce..000000000000
--- a/app-mobilephone/gnokii/files/gnokii-9999-icon.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/xgnokii/xgnokii.desktop.in
-+++ b/xgnokii/xgnokii.desktop.in
-@@ -2,7 +2,7 @@
- _Name=Xgnokii
- _GenericName=Mobile Phone Suite
- _Comment=Manage your mobile phone
--Icon=phone
-+Icon=xgnokii
- Exec=xgnokii
- Terminal=false
- Type=Application
diff --git a/app-mobilephone/gnokii/files/gnokii-9999-translations.patch b/app-mobilephone/gnokii/files/gnokii-9999-translations.patch
deleted file mode 100644
index 2f61cc222738..000000000000
--- a/app-mobilephone/gnokii/files/gnokii-9999-translations.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/po/POTFILES.in
-+++ b/po/POTFILES.in
-@@ -57,6 +57,7 @@
- smsd/pq.c
- smsd/smsd.c
- smsd/sqlite.c
-+utils/gnokii-configure.glade
- utils/mgnokiidev.c
- xgnokii/xgnokii.c
- xgnokii/xgnokii_calendar.c
diff --git a/app-mobilephone/gnokii/gnokii-0.6.31-r5.ebuild b/app-mobilephone/gnokii/gnokii-0.6.31-r5.ebuild
index 39bfdaea1f8e..ecb43f31fb9f 100644
--- a/app-mobilephone/gnokii/gnokii-0.6.31-r5.ebuild
+++ b/app-mobilephone/gnokii/gnokii-0.6.31-r5.ebuild
@@ -5,20 +5,13 @@ EAPI=8
inherit autotools desktop linux-info strip-linguas
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="
- git://git.savannah.nongnu.org/${PN}.git
- http://git.savannah.gnu.org/r/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://www.gnokii.org/download/${PN}/${P}.tar.bz2"
- KEYWORDS="amd64 ~arm64 ~hppa ~ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-fi
HOMEPAGE="https://www.gnokii.org/"
DESCRIPTION="User space driver and tools for use with mobile phones"
+SRC_URI="https://www.gnokii.org/download/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="amd64 ~arm64 ~hppa ~ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="bluetooth debug ical irda mysql nls +pcsc-lite postgres sms usb X"
RDEPEND="
@@ -59,13 +52,6 @@ PATCHES=(
)
src_prepare() {
- if [[ ${PV} == *9999 ]]; then
- local PATCHES=(
- "${FILESDIR}"/${P}-icon.patch
- "${FILESDIR}"/${P}-translations.patch
- )
- fi
-
default
sed -i -e "s:/usr/local:${EPREFIX}/usr:" Docs/sample/gnokiirc || die
@@ -142,10 +128,4 @@ pkg_postinst() {
elog "Make sure the user that runs gnokii has read/write access to the device"
elog "which your phone is connected to."
elog "The simple way of doing that is to add your user to the uucp group."
- if [[ ${PV} == *9999 ]]; then
- elog "This is the GIT version of ${PN}. It is experimental but may have important bug fixes."
- elog "You can keep track of the most recent commits at:"
- elog " http://git.savannah.gnu.org/cgit/gnokii.git/"
- elog "Whenever there is a change you are interested in, you can re-emerge ${P}."
- fi
}
diff --git a/app-mobilephone/gnokii/gnokii-9999.ebuild b/app-mobilephone/gnokii/gnokii-9999.ebuild
deleted file mode 100644
index 5031ffef4a3d..000000000000
--- a/app-mobilephone/gnokii/gnokii-9999.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools desktop linux-info strip-linguas
-
-HOMEPAGE="https://www.gnokii.org/"
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="
- git://git.savannah.nongnu.org/${PN}.git
- http://git.savannah.gnu.org/r/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://www.gnokii.org/download/${PN}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-fi
-DESCRIPTION="User space driver and tools for use with mobile phones"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="bluetooth debug ical irda mysql nls +pcsc-lite postgres sms usb X"
-
-RDEPEND="
- !app-mobilephone/smstools
- bluetooth? ( kernel_linux? ( net-wireless/bluez ) )
- ical? ( dev-libs/libical:= )
- pcsc-lite? ( sys-apps/pcsc-lite )
- sms? (
- dev-libs/glib:2
- postgres? ( dev-db/postgresql:* )
- mysql? ( dev-db/mysql-connector-c:= )
- )
- usb? ( virtual/libusb:0 )
- X? ( x11-libs/gtk+:2 )"
-DEPEND="${RDEPEND}
- dev-util/intltool
- irda? ( virtual/os-headers )
- nls? ( sys-devel/gettext )"
-
-CONFIG_CHECK="~UNIX98_PTYS"
-
-S="${WORKDIR}/${PN}-${PV%.1}"
-
-# Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
-MY_AVAILABLE_LINGUAS=" cs de et fi fr it nl pl pt sk sl sv zh_CN"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix_xgnokii_inclusion.patch
- "${FILESDIR}"/${P}-gcc5.patch
-)
-
-src_prepare() {
- [[ ${PV} == *9999 ]] && \
- PATCHES=(
- "${FILESDIR}"/${P}-icon.patch
- "${FILESDIR}"/${P}-translations.patch
- )
-
- sed -i -e "s:/usr/local:${EPREFIX}/usr:" Docs/sample/gnokiirc || die
-
- default
-
- eautoreconf
-}
-
-src_configure() {
- strip-linguas ${MY_AVAILABLE_LINGUAS}
-
- local config_xdebug
- if use X && use debug; then
- config_xdebug="--enable-xdebug"
- else
- config_xdebug="--disable-xdebug"
- fi
-
- econf \
- --disable-static \
- --disable-unix98test \
- $(use_enable bluetooth) \
- ${config_xdebug} \
- $(use_enable debug fulldebug) \
- $(use_enable debug rlpdebug) \
- $(use_enable ical libical) \
- $(use_enable irda) \
- $(use_enable mysql) \
- $(use_enable nls) \
- $(use_enable pcsc-lite libpcsclite) \
- $(use_enable postgres) \
- $(use_enable sms smsd) \
- $(use_enable usb libusb) \
- $(use_with X x)
-}
-
-src_test() {
- echo common/phones/fake.c >> po/POTFILES.in || die
- default
-}
-
-src_install() {
- default
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
-
- insinto /etc
- doins Docs/sample/gnokiirc
-
- # only one file needs suid root to make a pseudo device
- fperms 4755 /usr/sbin/mgnokiidev
-
- use X && newicon Docs/sample/logo/gnokii.xpm xgnokii.xpm
-
- if use sms; then
- cd smsd || die
-
- docinto smsd
- use mysql && dodoc sms.tables.mysql.sql README.MySQL
- use postgres && dodoc sms.tables.pq.sql
- dodoc README ChangeLog README.Tru64 action
- fi
-}
-
-pkg_postinst() {
- elog "Make sure the user that runs gnokii has read/write access to the device"
- elog "which your phone is connected to."
- elog "The simple way of doing that is to add your user to the uucp group."
- if [[ ${PV} == *9999 ]]; then
- elog "This is the GIT version of ${PN}. It is experimental but may have important bug fixes."
- elog "You can keep track of the most recent commits at:"
- elog " http://git.savannah.gnu.org/cgit/gnokii.git/"
- elog "Whenever there is a change you are interested in, you can re-emerge ${P}."
- fi
-}