summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-10-04 04:04:00 +0100
committerMarek Szuba <marecki@gentoo.org>2022-10-04 04:13:03 +0100
commita875aa576c8ac0578f63e5a24e190129dad2733b (patch)
tree4a1e074d094b61fa7ef083ba942d13a13116c334 /app-misc
parentmedia-sound/easyeffects: require gcc to build 6.3.0 (diff)
downloadgentoo-a875aa576c8ac0578f63e5a24e190129dad2733b.tar.gz
gentoo-a875aa576c8ac0578f63e5a24e190129dad2733b.tar.bz2
gentoo-a875aa576c8ac0578f63e5a24e190129dad2733b.zip
app-misc/ola: new package, add 0.10.8
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ola/Manifest1
-rw-r--r--app-misc/ola/metadata.xml23
-rw-r--r--app-misc/ola/ola-0.10.8.ebuild61
3 files changed, 85 insertions, 0 deletions
diff --git a/app-misc/ola/Manifest b/app-misc/ola/Manifest
new file mode 100644
index 000000000000..8994df22e307
--- /dev/null
+++ b/app-misc/ola/Manifest
@@ -0,0 +1 @@
+DIST ola-0.10.8.tar.gz 2552023 BLAKE2B b4fa7e36e2b907e8f0ea16ef089607fc223afc543752a03740fd1d525062ea676d2f392bb623804543827d6f5ac6078c469a3edcb4321bca9a454b1c219f9c89 SHA512 78ef8cc7f8e8d0b1d15bbb305d99a589fce82e07e89ca3bf2466bef8cdc1b18f590fc8dcbf29fc5af2349e0721c832f525fd665d62498907554ee742d79cd3d2
diff --git a/app-misc/ola/metadata.xml b/app-misc/ola/metadata.xml
new file mode 100644
index 000000000000..fe23c959e3e0
--- /dev/null
+++ b/app-misc/ola/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ The Open Lighting Architecture is a framework for lighting control information.
+ It supports a range of protocols and over a dozen USB devices. It can run as a
+ standalone service, which is useful for converting signals between protocols,
+ or alternatively using the OLA API, it can be used as the backend for lighting
+ control software. OLA runs on many different platforms including ARM, which
+ makes it a perfect fit for low cost Ethernet to DMX gateways.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">OpenLightingProject/ola</remote-id>
+ </upstream>
+ <use>
+ <flag name="ftdi">Support FTDI devices</flag>
+ <flag name="http">Enable built-in Web UI</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-misc/ola/ola-0.10.8.ebuild b/app-misc/ola/ola-0.10.8.ebuild
new file mode 100644
index 000000000000..e9fa6752713f
--- /dev/null
+++ b/app-misc/ola/ola-0.10.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Open Lighting Architecture, a framework for lighting control information"
+HOMEPAGE="https://www.openlighting.org/ola/"
+SRC_URI="https://github.com/OpenLightingProject/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples ftdi http osc tcmalloc test usb zeroconf"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/protobuf:=
+ sys-apps/util-linux
+ sys-libs/ncurses
+ ftdi? ( dev-embedded/libftdi:1 )
+ http? ( net-libs/libmicrohttpd:= )
+ osc? ( media-libs/liblo )
+ tcmalloc? ( dev-util/google-perftools:= )
+ usb? ( virtual/libusb:1 )
+ zeroconf? ( net-dns/avahi )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers"
+BDEPEND="sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ test? (
+ dev-util/cppunit
+ )"
+
+src_prepare() {
+ default
+ # Upstream recommends doing this even for tarball builds
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-fatal-warnings
+ --with-uucp-lock="/run"
+ $(use_enable examples)
+ $(use_enable ftdi libftdi)
+ $(use_enable http)
+ $(use_enable osc)
+ $(use_enable tcmalloc)
+ $(use_enable test unittests)
+ $(use_enable usb libusb)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}