summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2025-01-07 11:41:35 -0800
committerPatrick McLean <chutzpah@gentoo.org>2025-01-07 13:57:30 -0800
commit999ec4eba5ea6ee22ea84b89e82663892087720f (patch)
treefd79da5dcd5652ea6149d00415bc20385f5fbde7 /app-misc
parentdev-ada/gprbuild: use python-any-r1 (diff)
downloadgentoo-999ec4eba5ea6ee22ea84b89e82663892087720f.tar.gz
gentoo-999ec4eba5ea6ee22ea84b89e82663892087720f.tar.bz2
gentoo-999ec4eba5ea6ee22ea84b89e82663892087720f.zip
app-misc/solaar: add 1.1.14
Uses udev and dbus fixes from GitHub PR #39976 by NHOrus. Add python3.13, drop DISTUTILS_SINGLE_IMPL. Bug: https://bugs.gentoo.org/942070 Bug: https://bugs.gentoo.org/933418 Closes: https://bugs.gentoo.org/947490 Closes: https://github.com/gentoo/gentoo/pull/39976 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/solaar/Manifest1
-rw-r--r--app-misc/solaar/solaar-1.1.14.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/app-misc/solaar/Manifest b/app-misc/solaar/Manifest
index 1101a7a1f551..826817b8cfb9 100644
--- a/app-misc/solaar/Manifest
+++ b/app-misc/solaar/Manifest
@@ -1,3 +1,4 @@
DIST solaar-1.1.13.tar.gz 1779788 BLAKE2B fd138c3c9faa467e356240e8cfc73f420776228f407092cc2f8bca3a9443e4820dad923c8d997d41934fbf7fd728b17a9674c7f9affaf4cd8616c779f6141ff1 SHA512 4557c82bddf88a604e9316806b8d37296acc4b4486a64605199f85949f6b5d5fd5dd94b25742e5b41d01fba4da40dd5ab2e354d536856ecf3310557b4a7d23a0
+DIST solaar-1.1.14.tar.gz 1790657 BLAKE2B bc2d2d42e4af02f72ecf9fb25152605582ada758b30c4019d7579a81f082bb121b18369ba349ae9c73401548d41cb321ed43415cd9dbad65d3919f58d1e93470 SHA512 2af8785a36b085e42ba885d8380fe9a967eb864a7443e4a96e6ab04cd3e2128ce6c0540c74d327953cc446f463bcc1d5d20c303ef14196b70e7e552e0caceaf9
DIST solaar-1.1.8.tar.gz 1550947 BLAKE2B a33879e3c1b161d86c4c8a2c8edcc79eff285cb8937bf1e6621f3595ba5cf420e75fe700902b9f375698085bb929401154fa2bd25ae9663265e38c8406205bf6 SHA512 543c6257b36181813c9ed36747e53a15403da251fdd431c32525cada3ac88611da2c5f2a8212767ba3c7bb0071a3c2024f114805d9a33c761701bf958df29d85
DIST solaar-1.1.9.tar.gz 1564119 BLAKE2B 67161bdd2a59ff17cafcdc5399f9f0c072985df85b2d0408e54c8f4e4966c3602a2b62f93b90e56e80fb3c4cbd285de2bbcc87a7709bea06ee4394f42a16f52e SHA512 42ea592aa8c4020be5e2ffd096de0bf6a7e6fdfac7eb2acd069c80084f88979398f779db6507b8b2cc4fd44c8a2ffce89024a42c161f130b4e1bd2c53e4e73a9
diff --git a/app-misc/solaar/solaar-1.1.14.ebuild b/app-misc/solaar/solaar-1.1.14.ebuild
new file mode 100644
index 000000000000..a9edbf132724
--- /dev/null
+++ b/app-misc/solaar/solaar-1.1.14.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit linux-info udev xdg distutils-r1
+
+DESCRIPTION="Linux Device Manager for Logitech Unifying Receivers and Paired Devices"
+HOMEPAGE="https://pwr-solaar.github.io/Solaar/"
+if [[ ${PV} =~ 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pwr-Solaar/Solaar"
+else
+ SRC_URI="https://github.com/pwr-Solaar/Solaar/archive/${PV/_rc/rc}.tar.gz -> ${P/_rc/rc}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}"/Solaar-${PV/_rc/rc}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="appindicator dbus doc libnotify test wayland"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-group/plugdev
+ dev-python/evdev[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ >=dev-python/pyudev-0.13[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ appindicator? ( dev-libs/libayatana-appindicator )
+ libnotify? ( x11-libs/libnotify[introspection] )
+ dbus? ( dev-python/dbus-python )
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+# libayatana-appindicator & libnotify are entirely optional and detected at runtime
+
+CONFIG_CHECK="~HID_LOGITECH_DJ ~HIDRAW"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't autostart (bug #494608)
+ sed -r \
+ -e '/yield autostart_path/d' \
+ -e '/yield.*udev.*rules.d/{s,/etc,/lib,g}' \
+ -i setup.py || die
+
+ # grant plugdev group rw access
+ sed 's/#MODE=/MODE=/' \
+ -i rules.d/42-logitech-unify-permissions.rules || die
+ # and the same for wayland (bug #933418)
+ sed 's/#MODE=/MODE=/' \
+ -i rules.d-uinput/42-logitech-unify-permissions.rules || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc docs/devices.md CHANGELOG.md
+ if use doc; then
+ dodoc -r docs/*
+ else
+ newdoc docs/index.md README.md
+ fi
+
+ # bug #933418
+ if use wayland; then
+ udev_dorules "${S}"/rules.d-uinput/42-logitech-unify-permissions.rules
+ else
+ udev_dorules "${S}"/rules.d/42-logitech-unify-permissions.rules
+ fi
+}
+
+python_test() {
+ local -a EPYTEST_DESELECT=(
+ # don't like sandbox
+ tests/logitech_receiver/test_desktop_notifications.py::test_notifications_available
+ tests/logitech_receiver/test_desktop_notifications.py::test_init
+ tests/logitech_receiver/test_desktop_notifications.py::test_show
+ tests/solaar/ui/test_desktop_notifications.py::test_notifications_available
+ tests/solaar/ui/test_desktop_notifications.py::test_init
+ )
+
+ distutils-r1_python_test
+}
+
+pkg_postinst() {
+ udev_reload
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ udev_reload
+ xdg_pkg_postrm
+}