summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-03-14 23:38:55 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-14 23:39:50 +0100
commitf4228e8084ecdbf6ce06829fde9fcc0c50fea150 (patch)
treecbe3b50ccb516c5e370e23fd7ae5c2cab7b7edde /app-misc/tmux-xpanes/tmux-xpanes-4.1.0.ebuild
parentdev-python/django-mptt: django modified preorder tree traversal utilities (diff)
downloadgentoo-f4228e8084ecdbf6ce06829fde9fcc0c50fea150.tar.gz
gentoo-f4228e8084ecdbf6ce06829fde9fcc0c50fea150.tar.bz2
gentoo-f4228e8084ecdbf6ce06829fde9fcc0c50fea150.zip
app-misc/tmux-xpanes: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-misc/tmux-xpanes/tmux-xpanes-4.1.0.ebuild')
-rw-r--r--app-misc/tmux-xpanes/tmux-xpanes-4.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/tmux-xpanes/tmux-xpanes-4.1.0.ebuild b/app-misc/tmux-xpanes/tmux-xpanes-4.1.0.ebuild
new file mode 100644
index 000000000000..75d8c2d638d8
--- /dev/null
+++ b/app-misc/tmux-xpanes/tmux-xpanes-4.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="tmux-based terminal divider"
+HOMEPAGE="https://github.com/greymd/tmux-xpanes"
+SRC_URI="https://github.com/greymd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="zsh-completion"
+
+RDEPEND="
+ app-misc/tmux
+ dev-lang/perl
+ dev-libs/openssl:0=
+ zsh-completion? ( app-shells/zsh )"
+
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+DOCS=( CONTRIBUTING.md LICENSE README.md )
+
+src_install() {
+ dobin bin/*
+ doman man/*.1
+ einstalldocs
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins completion/zsh/*
+ fi
+}