summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-02-07 16:30:29 +0800
committerYixun Lan <dlan@gentoo.org>2023-02-07 16:34:55 +0800
commitf07f87a5e308b534930011dc505337e24a9051dd (patch)
tree6e0b942fc68d9b6d91fc75440197fa863bc221f6 /app-misc/tmate
parentprofiles: last-rite commons-text, jspeex, osgi-annotation-versioning (diff)
downloadgentoo-f07f87a5e308b534930011dc505337e24a9051dd.tar.gz
gentoo-f07f87a5e308b534930011dc505337e24a9051dd.tar.bz2
gentoo-f07f87a5e308b534930011dc505337e24a9051dd.zip
app-misc/tmate: drop IUSE=static-libs
updated, due to dev-libs/msgpack will remove IUSE=static-libs Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-misc/tmate')
-rw-r--r--app-misc/tmate/tmate-2.4.0-r1.ebuild (renamed from app-misc/tmate/tmate-2.4.0.ebuild)19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-misc/tmate/tmate-2.4.0.ebuild b/app-misc/tmate/tmate-2.4.0-r1.ebuild
index 362ba28cb0f9..25034bb83628 100644
--- a/app-misc/tmate/tmate-2.4.0.ebuild
+++ b/app-misc/tmate/tmate-2.4.0-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
@@ -11,17 +11,17 @@ HOMEPAGE="https://tmate.io/"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~riscv ~x86"
-IUSE="debug static-libs"
+IUSE="debug"
SRC_URI="https://github.com/tmate-io/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
RDEPEND="
- sys-libs/zlib[static-libs?]
- sys-libs/libutempter[static-libs?]
- dev-libs/libevent[static-libs?]
- dev-libs/msgpack[static-libs?]
- >=net-libs/libssh-0.6.0[static-libs?]
- dev-libs/openssl:0=[static-libs?]
+ sys-libs/zlib
+ sys-libs/libutempter
+ dev-libs/libevent
+ dev-libs/msgpack
+ >=net-libs/libssh-0.6.0
+ dev-libs/openssl:0=
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -34,6 +34,7 @@ src_prepare() {
src_configure() {
local myeconfargs=(
$(use_enable debug)
+ --disable-static
)
econf "${myeconfargs[@]}"
}