summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-19 01:51:19 +0000
committerSam James <sam@gentoo.org>2023-03-19 01:51:19 +0000
commitcd25dba2787287e20262d715509b795788347165 (patch)
tree86142c37ed94392317a0d33702cffb07ac16c119 /app-misc/timestamp
parentnet-im/cpop: fix configure w/ clang 16 (diff)
downloadgentoo-cd25dba2787287e20262d715509b795788347165.tar.gz
gentoo-cd25dba2787287e20262d715509b795788347165.tar.bz2
gentoo-cd25dba2787287e20262d715509b795788347165.zip
app-misc/timestamp: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/900481 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/timestamp')
-rw-r--r--app-misc/timestamp/timestamp-1.1-r3.ebuild (renamed from app-misc/timestamp/timestamp-1.1-r2.ebuild)11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-misc/timestamp/timestamp-1.1-r2.ebuild b/app-misc/timestamp/timestamp-1.1-r3.ebuild
index 07b66665a018..e5086f9fa791 100644
--- a/app-misc/timestamp/timestamp-1.1-r2.ebuild
+++ b/app-misc/timestamp/timestamp-1.1-r3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit autotools
+
DESCRIPTION="A text filtering pipe that marks each line with a timestamp"
HOMEPAGE="http://math.smsu.edu/~erik/software.php?id=95"
SRC_URI="http://math.smsu.edu/~erik/files/${P}.tar.gz"
@@ -12,3 +14,10 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
RDEPEND="!sys-apps/moreutils"
+
+src_prepare() {
+ default
+
+ # Clang 16, bug #900481
+ eautoreconf
+}