summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2022-12-25 18:07:59 +0000
committerMaciej Barć <xgqt@gentoo.org>2023-01-05 15:31:11 +0100
commit1a5f44d0989d0302a638a12268dff404d6caa8ee (patch)
tree160b492363bfbc0388a9f71892c22e033c8c3fe1 /app-misc/openrgb-plugin-visualmap
parentapp-misc/openrgb-plugin-skin: add 0.8 (diff)
downloadgentoo-1a5f44d0989d0302a638a12268dff404d6caa8ee.tar.gz
gentoo-1a5f44d0989d0302a638a12268dff404d6caa8ee.tar.bz2
gentoo-1a5f44d0989d0302a638a12268dff404d6caa8ee.zip
app-misc/openrgb-plugin-visualmap: add 0.8
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/28800 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-misc/openrgb-plugin-visualmap')
-rw-r--r--app-misc/openrgb-plugin-visualmap/Manifest1
-rw-r--r--app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch18
-rw-r--r--app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild47
3 files changed, 66 insertions, 0 deletions
diff --git a/app-misc/openrgb-plugin-visualmap/Manifest b/app-misc/openrgb-plugin-visualmap/Manifest
index de0c1e193754..007d9b9a17b0 100644
--- a/app-misc/openrgb-plugin-visualmap/Manifest
+++ b/app-misc/openrgb-plugin-visualmap/Manifest
@@ -1 +1,2 @@
DIST OpenRGBVisualMapPlugin-223c5ec67d256c5fa3bf7f3d572213114d93db6e.tar.bz2 54289 BLAKE2B b42b59fdc31f48d3e7be28051ccb02a2ba1befa1b1ed180a9313c8cbc50bad1c358ab5b4d8f249b488d5f32c801426078ef6c0c3c46dbec9695cb7b7cbf21d40 SHA512 eff52debcd027176a761fba71fb33d4a04802dd8f2441a86a825f3afecb268d2768edb8b03ec35ff2d17b5dc6f95dd0642e7d524fa7fcf93f0d215d712e75f3e
+DIST OpenRGBVisualMapPlugin-release_0.8.tar.bz2 51680 BLAKE2B c3423779f7a2082c8f682b519be2e1128b30dafbc4400414bd664f98de5c58701fbdbe9287a44951e8cf6ac4ee7c940a841f499ee1afce107e17537ad9df076b SHA512 7bf0393bc00bb69545ed02f6505f366aa90bb87350de6319977d02ba0afd38ccb895aa14edf02a42242b0a12f76ea2b135d8de5b3df10469c760b6f3d9dd2b61
diff --git a/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch b/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch
new file mode 100644
index 000000000000..b2023fa1df3a
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch
@@ -0,0 +1,18 @@
+--- a/OpenRGBVisualMapPlugin.pro
++++ b/OpenRGBVisualMapPlugin.pro
+@@ -96,7 +96,6 @@ HEADERS +=
+ OpenRGB/qt/hsv.h \
+
+ SOURCES += \
+- OpenRGB/RGBController/RGBController.cpp \
+ OpenRGBVisualMapPlugin.cpp \
+ VirtualController.cpp \
+ VisualMapSettingsManager.cpp \
+@@ -120,7 +119,6 @@ SOURCES +=
+ ui/widget-editor/EditorGrid.cpp \
+ ui/widget-editor/LedItem.cpp \
+ ui/widget-editor/WidgetEditor.cpp \
+- OpenRGB/qt/hsv.cpp \
+
+ FORMS += \
+ ui/BackgroundApplier.ui \
diff --git a/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild
new file mode 100644
index 000000000000..d6abfbf2af1c
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin/-/archive/release_${PV}/OpenRGBVisualMapPlugin-release_${PV}.tar.bz2"
+S="${WORKDIR}/OpenRGBVisualMapPlugin-release_${PV}"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Plugin for OpenRGB to create virtual devices out of multiple real ones"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.8:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dep.patch"
+)
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBVisualMapPlugin.so.1.0.0
+}