summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/mepl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/mepl')
-rw-r--r--app-misc/mepl/Manifest1
-rw-r--r--app-misc/mepl/files/gcc433.patch16
-rw-r--r--app-misc/mepl/mepl-0.45.ebuild36
-rw-r--r--app-misc/mepl/metadata.xml7
4 files changed, 60 insertions, 0 deletions
diff --git a/app-misc/mepl/Manifest b/app-misc/mepl/Manifest
new file mode 100644
index 000000000000..bd802e36b55b
--- /dev/null
+++ b/app-misc/mepl/Manifest
@@ -0,0 +1 @@
+DIST mepl0.45.tar.gz 18968 SHA256 2a42634428ac6f54536ca40f05417babf5f27c7a2821b77a21d84cc1627ca62b SHA512 679ac7548f6a4870164410db403d9fb8a18d7daa651a29d8e0dd87d8d3fdf1f9e8d381513ab922188951eba0798b1d32eadceafa117236ff54ef3e645d876c1e WHIRLPOOL c1c49075c186ce5228664510df84909d356950d5aea9aa80777ea5285c3e06dd95a27d3000fbe63555ed4e772c151dc56902f4ea7b50581beb6afbd552d1ea31
diff --git a/app-misc/mepl/files/gcc433.patch b/app-misc/mepl/files/gcc433.patch
new file mode 100644
index 000000000000..821f1330e377
--- /dev/null
+++ b/app-misc/mepl/files/gcc433.patch
@@ -0,0 +1,16 @@
+--- mepl.c 2009-04-07 21:17:32.000000000 +0200
++++ mepl.c.new 2009-04-07 21:16:48.000000000 +0200
+@@ -1,3 +1,4 @@
++#include <stdlib.h>
+ #define VERSION "0.45 Don Nov 25 19:13:58 CET 1999"
+ /* Version: @(#) mepl.c 0.45
+ Autor: Frank Holtz <frank@hof-berlin.de>--- mepl.c 2009-04-07 21:08:18.000000000 +0200
+@@ -347,7 +347,7 @@
+ errz=0;
+ do {
+ error=0;
+- resout=open(resdat,O_WRONLY | O_TRUNC | O_CREAT); /* In Datei zwischenspeichern */
++ resout=open(resdat,O_WRONLY | O_TRUNC | O_CREAT,0600); /* In Datei zwischenspeichern */
+ sendstr(ATSENDMEM);
+ line[2]=0;
+ /* Erstes Zeichen suchen */
diff --git a/app-misc/mepl/mepl-0.45.ebuild b/app-misc/mepl/mepl-0.45.ebuild
new file mode 100644
index 000000000000..e1235218c0f1
--- /dev/null
+++ b/app-misc/mepl/mepl-0.45.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Self-employed-mode software for 3COM/USR message modems"
+HOMEPAGE="http://www.hof-berlin.de/mepl/"
+SRC_URI="http://www.hof-berlin.de/mepl/mepl${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/gcc433.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -DMEPLCONFIG=\\\"/etc/mepl.conf\\\"\
+ ${LDFLAGS}" en || die
+}
+
+src_install() {
+ dobin mepl meplmail || die
+ insinto /etc
+ doins mepl.conf
+ newman mepl.en mepl.7
+}
diff --git a/app-misc/mepl/metadata.xml b/app-misc/mepl/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/app-misc/mepl/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>