summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-04-21 13:46:18 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-04-21 13:46:18 -0700
commite86ce217ac592d335a008684c533b3b0eff2b19f (patch)
tree3bd7ae12347d80658a7bc265805531f9690b6f61 /app-misc/icdiff
parentnet-misc/netopeer2: Add dependency on c_rehash (diff)
downloadgentoo-e86ce217ac592d335a008684c533b3b0eff2b19f.tar.gz
gentoo-e86ce217ac592d335a008684c533b3b0eff2b19f.tar.bz2
gentoo-e86ce217ac592d335a008684c533b3b0eff2b19f.zip
app-misc/icdiff: add 2.0.6
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/icdiff')
-rw-r--r--app-misc/icdiff/Manifest1
-rw-r--r--app-misc/icdiff/files/icdiff-2.0.6-tests.patch40
-rw-r--r--app-misc/icdiff/icdiff-2.0.6.ebuild29
3 files changed, 70 insertions, 0 deletions
diff --git a/app-misc/icdiff/Manifest b/app-misc/icdiff/Manifest
index 69855a9847fb..19af1998942b 100644
--- a/app-misc/icdiff/Manifest
+++ b/app-misc/icdiff/Manifest
@@ -1,2 +1,3 @@
DIST icdiff-1.9.5.tar.gz 31914 BLAKE2B 8d9b9b5104c3075addae2954b41c27ccebe3b4723b0e71ef88a214d7fa0ff7d8cb9ac52cada8ddec929d308a356daf37ef4463a52667f7e229a4a33d1d993e86 SHA512 f4c50da1e73a1af2fd63feabfd180125637a856a8757356eb3b48bbc21871f36a2c876acd2e2ba9d354c8f6e658f6e262fbbfd65fa4078d0adebc1353d87e40a
DIST icdiff-2.0.5.tar.gz 33806 BLAKE2B b8b17f72ed32923fa436713f28263bd79ac899cc291581ba4aac4bbe64daa1749e10fb63ea597be58e5557854757943aeb2c718fa972496d12c24a2071248550 SHA512 9ac3705ba8fbc277b9af2c47a5b791bb8ed98da0546410cafc206992e25e98cc7fba6e920d6acd1a576c609be853ad52a5680e456a9c70132c5f323fb4b6694d
+DIST icdiff-2.0.6.tar.gz 39715 BLAKE2B 931799040c158c522b3788941bddaef074a5e769cc56b6d80ca9515ee0c437e0ec0b7453c7409133c5567b98e7d41355e1d9f647d1939c78d07c2bf4c010fa5e SHA512 23ed93cc68ae44e661d61cef7e489249fc39e9f8fd18cac5551e89a713aef8cd2ecb37b0f301f543a4ba7003c74b5a311430ab8666760a76ee8441a4ac920ff5
diff --git a/app-misc/icdiff/files/icdiff-2.0.6-tests.patch b/app-misc/icdiff/files/icdiff-2.0.6-tests.patch
new file mode 100644
index 000000000000..d45073ebbd86
--- /dev/null
+++ b/app-misc/icdiff/files/icdiff-2.0.6-tests.patch
@@ -0,0 +1,40 @@
+diff --git a/test.sh b/test.sh
+index 317a752..10456ff 100755
+--- a/test.sh
++++ b/test.sh
+@@ -158,9 +158,9 @@ check_gold 0 gold-identical-on.txt tests/input-{1,1}.txt -s
+ check_gold 2 gold-bad-encoding.txt tests/input-{1,2}.txt --encoding=nonexistend_encoding
+ check_gold 0 gold-recursive-with-exclude.txt --recursive -x c tests/{a,b} --cols=80
+ check_gold 1 gold-recursive-with-exclude2.txt --recursive -x 'excl*' tests/test-with-exclude/{a,b} --cols=80
+-check_gold 0 gold-exit-process-sub tests/input-1.txt <(cat tests/input-1.txt) --cols=80
++check_gold 0 gold-exit-process-sub tests/input-1.txt <(cat tests/input-1.txt) --no-headers --cols=80
+
+-rm tests/permissions-{a,b}
++rm -f tests/permissions-{a,b}
+ touch tests/permissions-{a,b}
+ check_gold 0 gold-permissions-same.txt tests/permissions-{a,b} -P --cols=80
+
+@@ -173,7 +173,7 @@ check_gold 1 gold-permissions-diff-text.txt tests/permissions-{a,b} -P --cols=80
+
+ echo -e "\04" >> tests/permissions-b
+ check_gold 1 gold-permissions-diff-binary.txt tests/permissions-{a,b} -P --cols=80
+-rm tests/permissions-{a,b}
++rm -f tests/permissions-{a,b}
+
+ if git show 4e86205629 &> /dev/null; then
+ # We're in the repo, so test git.
+@@ -209,7 +209,7 @@ function ensure_installed() {
+
+ ensure_installed "black"
+ echo 'Running black formatter...'
+-if ! black icdiff --line-length 79 --check; then
++if ! black icdiff --quiet --line-length 79 --check; then
+ echo ""
+ echo 'Consider running `black icdiff --line-length 79`'
+ fail
+diff --git a/tests/gold-exit-process-sub b/tests/gold-exit-process-sub
+index 3885e20..e69de29 100644
+--- a/tests/gold-exit-process-sub
++++ b/tests/gold-exit-process-sub
+@@ -1 +0,0 @@
+-tests/input-1.txt /dev/fd/63
diff --git a/app-misc/icdiff/icdiff-2.0.6.ebuild b/app-misc/icdiff/icdiff-2.0.6.ebuild
new file mode 100644
index 000000000000..1de8e780f963
--- /dev/null
+++ b/app-misc/icdiff/icdiff-2.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Colourized diff that supports side-by-side diffing"
+HOMEPAGE="https://www.jefftk.com/icdiff"
+SRC_URI="https://github.com/jeffkaufman/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}/icdiff-1.9.5-tests.patch"
+ "${FILESDIR}/icdiff-2.0.6-tests.patch"
+)
+
+DOCS=(README.md ChangeLog)
+
+python_test() {
+ bash test.sh "${EPYTHON%.*}" || die "Tests failed with ${EPYTHON}"
+}