summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-15 04:48:07 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-15 04:49:46 +0100
commite4404298a56ba681a275967c2fb4d6a2e061b891 (patch)
treeaeca4654de8a9dada17b88abc162ccadee59247b /app-misc/email2trac/email2trac-2.12.2.ebuild
parentapp-emulation/docker: stabilize 19.03.8 on amd64 (diff)
downloadgentoo-e4404298a56ba681a275967c2fb4d6a2e061b891.tar.gz
gentoo-e4404298a56ba681a275967c2fb4d6a2e061b891.tar.bz2
gentoo-e4404298a56ba681a275967c2fb4d6a2e061b891.zip
app-misc/email2trac: bump to v2.12.2
Non-maintainer bump to allow security cleanup of <www-apps/trac-1.2.x. Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-misc/email2trac/email2trac-2.12.2.ebuild')
-rw-r--r--app-misc/email2trac/email2trac-2.12.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/email2trac/email2trac-2.12.2.ebuild b/app-misc/email2trac/email2trac-2.12.2.ebuild
new file mode 100644
index 000000000000..b0afc6f55762
--- /dev/null
+++ b/app-misc/email2trac/email2trac-2.12.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="Utilities to convert emails to trac tickets"
+HOMEPAGE="https://oss.trac.surfsara.nl/email2trac"
+SRC_URI="ftp://ftp.sara.nl/pub/outgoing/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ <www-apps/trac-1.3[${PYTHON_SINGLE_USEDEP}]"
+
+pkg_setup() {
+ einfo "You can set the following variables in make.conf:"
+ einfo " - EMAIL2TRAC_TRAC_USER (default: apache)"
+ einfo " - EMAIL2TRAC_MTA_USER (default: nobody)"
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ sed -i -e "/^CFLAGS/s:=:&${CFLAGS} :" \
+ -e "s:\$(CC):& ${LDFLAGS} :" \
+ Makefile.in || die 'sed failed'
+}
+
+src_configure() {
+ econf --sysconfdir=/etc/${PN}/ \
+ --with-trac_user=${EMAIL2TRAC_TRAC_USER:-apache} \
+ --with-mta_user=${EMAIL2TRAC_MTA_USER:-nobody}
+}