summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/countrycodes/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/countrycodes/files')
-rw-r--r--app-misc/countrycodes/files/1.0.5-Makefile.patch42
-rw-r--r--app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch12
2 files changed, 54 insertions, 0 deletions
diff --git a/app-misc/countrycodes/files/1.0.5-Makefile.patch b/app-misc/countrycodes/files/1.0.5-Makefile.patch
new file mode 100644
index 000000000000..4ee47e32dfd2
--- /dev/null
+++ b/app-misc/countrycodes/files/1.0.5-Makefile.patch
@@ -0,0 +1,42 @@
+diff --git a/src/Makefile b/src/Makefile
+index 9330578..3ff7319 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -26,13 +26,13 @@ BINMODE=755
+ LOGDIRMODE=700
+
+ # Compiler to use
+-CC=gcc
++CC ?= gcc
+
+ # Compiler warnings
+-WARNINGS= -pedantic -Wall
++WARNINGS=
+
+ # Compiler flags
+-CCOPTS = -O2 -fomit-frame-pointer
++CCOPTS = ${CFLAGS}
+
+ # The makefile standards document I read says that I have to put it here...
+ SHELL = /bin/sh
+@@ -61,7 +61,7 @@ PROGRAM = iso3166
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(ISO3166OBJ)
+- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
++ $(CC) $(CCOPTS) $(LDFLAGS) $(ISO3166OBJ) -o $@
+
+ clean:
+ rm -f $(ISO3166OBJ) core defines.h $(PROGRAM)
+@@ -70,8 +70,10 @@ strip:
+ strip $(PROGRAM)
+
+ install:
+- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
++ mkdir -p ${bindir}
++ $(INSTALL) -g root -m $(BINMODE) -o root ${srcdir}/$(PROGRAM) ${bindir}
+ @echo "Installing man page..."
++ mkdir -p ${mandir}
+ @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
+ @chown 0.0 ${mandir}/iso3166.1
+ @echo
diff --git a/app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch b/app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch
new file mode 100644
index 000000000000..619d7a072360
--- /dev/null
+++ b/app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch
@@ -0,0 +1,12 @@
+diff -Naur countrycodes-1.0.5-orig/src/Makefile countrycodes-1.0.5/src/Makefile
+--- countrycodes-1.0.5-orig/src/Makefile 2003-02-01 09:56:08.000000000 -0600
++++ countrycodes-1.0.5/src/Makefile 2007-02-03 20:12:26.000000000 -0600
+@@ -70,7 +70,7 @@
+ strip $(PROGRAM)
+
+ install:
+- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
++ $(INSTALL) -g root -m $(BINMODE) -o root ${srcdir}/$(PROGRAM) ${bindir}
+ @echo "Installing man page..."
+ @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
+ @chown 0.0 ${mandir}/iso3166.1