summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2015-12-12 06:14:03 +0100
committerThomas Kahle <tomka@gentoo.org>2015-12-12 06:14:54 +0100
commit7980335cc8c2ec31e4775a1e328b70367c3be0ed (patch)
tree11131857ee9fd3ed347249a3ee920974df4abd67 /app-misc/anki/anki-2.0.33.ebuild
parentgames-emulation/dolphin - Bumps to version 5.0 (diff)
downloadgentoo-7980335cc8c2ec31e4775a1e328b70367c3be0ed.tar.gz
gentoo-7980335cc8c2ec31e4775a1e328b70367c3be0ed.tar.bz2
gentoo-7980335cc8c2ec31e4775a1e328b70367c3be0ed.zip
app-misc/anki: Bump to 2.0.33
Fixes bug 567958. Package-Manager: portage-2.2.24
Diffstat (limited to 'app-misc/anki/anki-2.0.33.ebuild')
-rw-r--r--app-misc/anki/anki-2.0.33.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-misc/anki/anki-2.0.33.ebuild b/app-misc/anki/anki-2.0.33.ebuild
new file mode 100644
index 000000000000..51896953783b
--- /dev/null
+++ b/app-misc/anki/anki-2.0.33.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit eutils python-single-r1
+
+DESCRIPTION="A spaced-repetition memory training program (flash cards)"
+HOMEPAGE="http://ichi2.net/anki/"
+SRC_URI="http://ankisrs.net/download/mirror/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="latex +recording +sound"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/PyQt4[X,svg,webkit]
+ >=dev-python/httplib2-0.7.4
+ dev-python/beautifulsoup:python-2
+ dev-python/send2trash
+ recording? ( media-sound/lame
+ >=dev-python/pyaudio-0.2.4 )
+ sound? ( media-video/mplayer )
+ latex? ( app-text/texlive
+ app-text/dvipng )"
+DEPEND=""
+
+pkg_setup(){
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -r thirdparty || die
+ sed -i -e "s/updates=True/updates=False/" \
+ aqt/profiles.py || die
+}
+
+# Nothing to configure or compile
+src_configure() {
+ true;
+}
+
+src_compile() {
+ true;
+}
+
+src_install() {
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ doman ${PN}.1
+
+ dodoc README README.development
+ python_domodule aqt anki
+ python_doscript anki/anki
+
+ # Localization files go into the anki directory:
+ python_moduleinto anki
+ python_domodule locale
+}