summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-03-25 13:15:53 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-03-25 13:16:38 -0500
commit1b3af9816cecc845ee74fb870ecb30d27ad6264a (patch)
tree69d3c675e6b0b75167b2bb8e0b573c15be94092b /app-metrics
parentdev-scheme/kawa: revbump (diff)
downloadgentoo-1b3af9816cecc845ee74fb870ecb30d27ad6264a.tar.gz
gentoo-1b3af9816cecc845ee74fb870ecb30d27ad6264a.tar.bz2
gentoo-1b3af9816cecc845ee74fb870ecb30d27ad6264a.zip
app-metrics/prometheus: add 2.43.0
Bug: https://bugs.gentoo.org/885109 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus/Manifest3
-rw-r--r--app-metrics/prometheus/prometheus-2.43.0.ebuild72
2 files changed, 75 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index 88cb8cc4ca83..ea659d0f3c49 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -7,3 +7,6 @@ DIST prometheus-2.40.4.tar.gz 6156657 BLAKE2B a522b31516f5e26475afa2d59a7074b7de
DIST prometheus-2.41.0-assets.tar.xz 45792212 BLAKE2B 79e494a983d1e666b2e706532c2bd16562382b458132af2c8f26ab684097bd70384e1a11d0926662592b0d3133cab4435b16d1e2d7f1cd3a3b237831cf762dc4 SHA512 a35ec5b31fa05f2f044b9b843095cf68913664f88a4b9f64479ae2392682a7a7c8cf5e7239340ff260bf151c92d06929284174371cac072d32355103d9257131
DIST prometheus-2.41.0-deps.tar.xz 254253988 BLAKE2B 8ba4697b53a99660d9191097fb734c1024b8b9a437c18d9eaf0a10e7e065364e34eb419751fce253188aa3ec6714ab1231ed85d11469dd76fe1eb76e4cdd4360 SHA512 87f591c93bec487210e9adf4c486f96fc02b708f923b4dd01f4e264a800190733f36718170f5da647e5aef4839214809e850ffac3cad17cb80957adaa80ef5a9
DIST prometheus-2.41.0.tar.gz 6184846 BLAKE2B 525fca8b006b0edf9c6c3e71120b4c11af1e08966108c21ab4897501f64d454b3ac2ac7c5f986485d2c1c2d2186f3dc131ad6df1499f5006fa68473de7fc0aed SHA512 87076421a9c641c3553fe039a5de6e6c0a63f44869895bc0741a446bd150a59ca77eaa4080bac61ecbc3c4bf378ea79fabe1e640710793cd8c83a20ba7e4a5e1
+DIST prometheus-2.43.0-assets.tar.xz 45483188 BLAKE2B 603ba713947954d5c54748cc5778d7c3f6f3ef90abbb73eb3b44269c4b2973290e408d284abe83d30d99107be6007feeb2078d70b4fba71a8b4e612cd7e923a2 SHA512 8a15a3ebbeb8ae27d20d036ee7a9eae09ca8829f8e5b96ebe662e078e57ec02c3654916f705101ea1e371d7b79a4ea9f98b3c3f0433137c7750699e6bf3e0d97
+DIST prometheus-2.43.0-deps.tar.xz 261021244 BLAKE2B b2f9af3e1f511135dd782f99aa552c6f20f2196eca95bd88643e4c29c03be81ce5e9fe8818c7700680cbac8c853a9f8c98cc10c517e28cecbf67db257a224019 SHA512 304f49997a8a466811b7a383a2512a47f15f0c0be878af1818698231d7bfbead8974bba31b30fdad59185c00915f45652a68b9f4b52950e81fe6dfa957906358
+DIST prometheus-2.43.0.tar.gz 6228230 BLAKE2B d004bb077c70849e7d9e0c28420582475f32d6b5541c12f3c79af02b897fd9df0847c27317cdffe7ccc4183a31e7d0d0535ce980dfe79b3a517a7a6d819645f3 SHA512 d84fcd064224c6b0a9306151ce96052bac53b5c08f6a69ced88e6424c65d1c6143e82a863ac5c9e348a7be97bc2caa38f64f521a5b050e710b474025f6e41014
diff --git a/app-metrics/prometheus/prometheus-2.43.0.ebuild b/app-metrics/prometheus/prometheus-2.43.0.ebuild
new file mode 100644
index 000000000000..db5a914685b6
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.43.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+GIT_COMMIT=edfc3bcd025dd6fe296c167a14a216cab1e552ee
+MY_PV=v${PV/_rc/-rc.}
+
+# To create the assets tarball run the following:
+# git checkout <tag>
+# make assets-compress
+# tar -acf <tarball> web/ui
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="https://github.com/prometheus/prometheus/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz
+ https://dev.gentoo.org/~williamh/dist/${P}-assets.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv"
+
+COMMON_DEPEND="acct-group/prometheus
+ acct-user/prometheus"
+DEPEND="!app-metrics/prometheus-bin
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND=">=dev-util/promu-0.3.0"
+
+RESTRICT=" test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/{{.Branch}}/HEAD/" \
+ -e "s/{{.Revision}}/${GIT_COMMIT}/" \
+ -e "s/{{.Version}}/${PV}/" \
+ .promu.yml || die
+ cp -a -n "${WORKDIR}"/web/ui web || die
+}
+
+src_compile() {
+ emake PROMU="${EPREFIX}"/usr/bin/promu common-build plugins
+}
+
+src_install() {
+ dobin prometheus promtool
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ dosym -r /usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym -r /usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ systemd_dounit "${FILESDIR}"/prometheus.service
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}