summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-08-15 13:58:02 +0800
committerSam James <sam@gentoo.org>2024-08-15 21:34:49 +0100
commitddcfaf999c852cd1b7ef4a68379d9e7615a1cfaf (patch)
treef55de3c283204a7a0180c841fb708e2a8f50b2be /app-i18n
parentapp-i18n/fcitx: fix missing cstdint for GCC 15 (diff)
downloadgentoo-ddcfaf999c852cd1b7ef4a68379d9e7615a1cfaf.tar.gz
gentoo-ddcfaf999c852cd1b7ef4a68379d9e7615a1cfaf.tar.bz2
gentoo-ddcfaf999c852cd1b7ef4a68379d9e7615a1cfaf.zip
app-i18n/libime: fix missing cstdint for GCC 15
Closes: https://bugs.gentoo.org/937738 Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38157 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/libime/files/libime-1.1.8-include-cstdint-for-gcc-15.patch12
-rw-r--r--app-i18n/libime/libime-1.1.8-r1.ebuild54
2 files changed, 66 insertions, 0 deletions
diff --git a/app-i18n/libime/files/libime-1.1.8-include-cstdint-for-gcc-15.patch b/app-i18n/libime/files/libime-1.1.8-include-cstdint-for-gcc-15.patch
new file mode 100644
index 000000000000..46221b19c5fc
--- /dev/null
+++ b/app-i18n/libime/files/libime-1.1.8-include-cstdint-for-gcc-15.patch
@@ -0,0 +1,12 @@
+https://github.com/fcitx/libime/pull/78
+
+--- a/src/libime/table/autophrasedict.h
++++ b/src/libime/table/autophrasedict.h
+@@ -8,6 +8,7 @@
+
+ #include "libimetable_export.h"
+ #include <cstddef>
++#include <cstdint>
+ #include <fcitx-utils/macros.h>
+ #include <functional>
+ #include <istream>
diff --git a/app-i18n/libime/libime-1.1.8-r1.ebuild b/app-i18n/libime/libime-1.1.8-r1.ebuild
new file mode 100644
index 000000000000..2b77704e6cb8
--- /dev/null
+++ b/app-i18n/libime/libime-1.1.8-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake unpacker
+
+DESCRIPTION="Fcitx5 Next generation of fcitx "
+HOMEPAGE="https://fcitx-im.org/"
+SRC_URI="https://download.fcitx-im.org/fcitx5/libime/libime-${PV}_dict.tar.zst"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+data doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.5:5
+ app-arch/zstd:=
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+ doc? (
+ app-text/doxygen
+ dev-texlive/texlive-fontutils
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-include-cstdint-for-gcc-15.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DATA=$(usex data)
+ -DENABLE_DOC=$(usex doc)
+ -DENABLE_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
+}