summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 16:51:40 +0000
committerSam James <sam@gentoo.org>2021-02-27 16:51:40 +0000
commitab3ec2595d0398dae2a2856122229b4454fe6a54 (patch)
tree0dcf97029b091435a86ce20620b3d97fb9375ece /app-i18n/transifex-client
parentapp-i18n/transifex-client: fix failing test on 32 bit systems (diff)
downloadgentoo-ab3ec2595d0398dae2a2856122229b4454fe6a54.tar.gz
gentoo-ab3ec2595d0398dae2a2856122229b4454fe6a54.tar.bz2
gentoo-ab3ec2595d0398dae2a2856122229b4454fe6a54.zip
app-i18n/transifex-client: un-rev bump for test-only fix
The fix here is only for the test itself, not the installed contents, so there's no need to force a reinstall for a fix to be applied on systems. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-i18n/transifex-client')
-rw-r--r--app-i18n/transifex-client/files/transifex-client-0.14.2-r1-timestamp.patch (renamed from app-i18n/transifex-client/files/transifex-client-timestamp.patch)8
-rw-r--r--app-i18n/transifex-client/transifex-client-0.14.2-r1.ebuild7
-rw-r--r--app-i18n/transifex-client/transifex-client-0.14.2-r2.ebuild37
3 files changed, 11 insertions, 41 deletions
diff --git a/app-i18n/transifex-client/files/transifex-client-timestamp.patch b/app-i18n/transifex-client/files/transifex-client-0.14.2-r1-timestamp.patch
index 9d1b2c46c762..0943621243c0 100644
--- a/app-i18n/transifex-client/files/transifex-client-timestamp.patch
+++ b/app-i18n/transifex-client/files/transifex-client-0.14.2-r1-timestamp.patch
@@ -1,6 +1,8 @@
-diff -Naur ../transifex-client-0.14.2.orig/tests/test_project.py ./tests/test_project.py
---- ../transifex-client-0.14.2.orig/tests/test_project.py 2020-06-19 14:48:52.000000000 +0200
-+++ ./tests/test_project.py 2021-02-25 22:08:29.353477306 +0100
+https://github.com/transifex/transifex-client/pull/316
+https://bugs.gentoo.org/771660
+Fix tests on 32-bit systems
+--- a/tests/test_project.py
++++ b/tests/test_project.py
@@ -717,8 +717,8 @@
)
self.assertEqual(res, True)
diff --git a/app-i18n/transifex-client/transifex-client-0.14.2-r1.ebuild b/app-i18n/transifex-client/transifex-client-0.14.2-r1.ebuild
index a1c433b28a70..49ec7a704570 100644
--- a/app-i18n/transifex-client/transifex-client-0.14.2-r1.ebuild
+++ b/app-i18n/transifex-client/transifex-client-0.14.2-r1.ebuild
@@ -25,10 +25,15 @@ RDEPEND="dev-python/GitPython[${PYTHON_USEDEP}]
<dev-python/six-2.0.0[${PYTHON_USEDEP}]
dev-python/urllib3[${PYTHON_USEDEP}]"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.14.2-r1-timestamp.patch"
+)
+
distutils_enable_tests setup.py
src_prepare() {
- eapply_user
+ default
+
sed -i -e 's:test_fetch_timestamp_from_git_tree:_&:' \
tests/test_utils.py || die
sed -i '/tests_require=\["mock>=3.0.5,<4.0"\]/d' setup.py || die
diff --git a/app-i18n/transifex-client/transifex-client-0.14.2-r2.ebuild b/app-i18n/transifex-client/transifex-client-0.14.2-r2.ebuild
deleted file mode 100644
index 7efb21927225..000000000000
--- a/app-i18n/transifex-client/transifex-client-0.14.2-r2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit eutils distutils-r1
-
-DESCRIPTION="A command line interface for Transifex"
-HOMEPAGE="https://pypi.org/project/transifex-client/ https://www.transifex.net/ https://github.com/transifex/transifex-client"
-SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-RDEPEND="dev-python/GitPython[${PYTHON_USEDEP}]
- <dev-python/python-slugify-5.0.0[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- <dev-python/six-2.0.0[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]"
-
-distutils_enable_tests setup.py
-
-src_prepare() {
- eapply_user
- sed -i -e 's:test_fetch_timestamp_from_git_tree:_&:' \
- tests/test_utils.py || die
- sed -i '/tests_require=\["mock>=3.0.5,<4.0"\]/d' setup.py || die
- # Bug 771660
- eapply "${FILESDIR}"/${PN}-timestamp.patch
-}