summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-18 17:35:36 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-18 17:35:58 -0500
commit5872ef1589f876b12fd87fcf00b5403f6c14f36d (patch)
treee9ea39d2593ccc6034e8a6b91273dad421626f3e /app-emulation
parentapp-emulation/wine-proton: pass -std=gnu17 for gcc15 for now (diff)
downloadgentoo-5872ef1589f876b12fd87fcf00b5403f6c14f36d.tar.gz
gentoo-5872ef1589f876b12fd87fcf00b5403f6c14f36d.tar.bz2
gentoo-5872ef1589f876b12fd87fcf00b5403f6c14f36d.zip
app-emulation/wine-staging: pass -std=gnu17 for gcc15 for now
Closes: https://bugs.gentoo.org/943849 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-staging/wine-staging-9.0.ebuild3
-rw-r--r--app-emulation/wine-staging/wine-staging-9.19.ebuild3
-rw-r--r--app-emulation/wine-staging/wine-staging-9.20.ebuild3
-rw-r--r--app-emulation/wine-staging/wine-staging-9.21.ebuild3
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild3
5 files changed, 15 insertions, 0 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9.0.ebuild b/app-emulation/wine-staging/wine-staging-9.0.ebuild
index f82e62bb333f..991310a78caf 100644
--- a/app-emulation/wine-staging/wine-staging-9.0.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.0.ebuild
@@ -328,6 +328,9 @@ src_configure() {
filter-flags -Wl,--gc-sections # runtime issues (bug #931329)
use custom-cflags || strip-flags # can break in obscure ways at runtime
+ # broken with gcc-15's c23 default (TODO: try w/o occasionally, bug #943849)
+ append-cflags -std=gnu17
+
# wine uses linker tricks unlikely to work with non-bfd/lld (bug #867097)
# (do self test until https://github.com/gentoo/gentoo/pull/28355)
if [[ $(LC_ALL=C $(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) != @(LLD|GNU\ ld)* ]]
diff --git a/app-emulation/wine-staging/wine-staging-9.19.ebuild b/app-emulation/wine-staging/wine-staging-9.19.ebuild
index 69c45f1c51f2..e0c51c2bc68d 100644
--- a/app-emulation/wine-staging/wine-staging-9.19.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.19.ebuild
@@ -321,6 +321,9 @@ src_configure() {
filter-flags -Wl,--gc-sections # runtime issues (bug #931329)
use custom-cflags || strip-flags # can break in obscure ways at runtime
+ # broken with gcc-15's c23 default (TODO: try w/o occasionally, bug #943849)
+ append-cflags -std=gnu17
+
# wine uses linker tricks unlikely to work with non-bfd/lld (bug #867097)
# (do self test until https://github.com/gentoo/gentoo/pull/28355)
if [[ $(LC_ALL=C $(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) != @(LLD|GNU\ ld)* ]]
diff --git a/app-emulation/wine-staging/wine-staging-9.20.ebuild b/app-emulation/wine-staging/wine-staging-9.20.ebuild
index 983b7367f85a..fb3dc75e7ce3 100644
--- a/app-emulation/wine-staging/wine-staging-9.20.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.20.ebuild
@@ -321,6 +321,9 @@ src_configure() {
filter-flags -Wl,--gc-sections # runtime issues (bug #931329)
use custom-cflags || strip-flags # can break in obscure ways at runtime
+ # broken with gcc-15's c23 default (TODO: try w/o occasionally, bug #943849)
+ append-cflags -std=gnu17
+
# wine uses linker tricks unlikely to work with non-bfd/lld (bug #867097)
# (do self test until https://github.com/gentoo/gentoo/pull/28355)
if [[ $(LC_ALL=C $(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) != @(LLD|GNU\ ld)* ]]
diff --git a/app-emulation/wine-staging/wine-staging-9.21.ebuild b/app-emulation/wine-staging/wine-staging-9.21.ebuild
index 983b7367f85a..fb3dc75e7ce3 100644
--- a/app-emulation/wine-staging/wine-staging-9.21.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.21.ebuild
@@ -321,6 +321,9 @@ src_configure() {
filter-flags -Wl,--gc-sections # runtime issues (bug #931329)
use custom-cflags || strip-flags # can break in obscure ways at runtime
+ # broken with gcc-15's c23 default (TODO: try w/o occasionally, bug #943849)
+ append-cflags -std=gnu17
+
# wine uses linker tricks unlikely to work with non-bfd/lld (bug #867097)
# (do self test until https://github.com/gentoo/gentoo/pull/28355)
if [[ $(LC_ALL=C $(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) != @(LLD|GNU\ ld)* ]]
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 983b7367f85a..fb3dc75e7ce3 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -321,6 +321,9 @@ src_configure() {
filter-flags -Wl,--gc-sections # runtime issues (bug #931329)
use custom-cflags || strip-flags # can break in obscure ways at runtime
+ # broken with gcc-15's c23 default (TODO: try w/o occasionally, bug #943849)
+ append-cflags -std=gnu17
+
# wine uses linker tricks unlikely to work with non-bfd/lld (bug #867097)
# (do self test until https://github.com/gentoo/gentoo/pull/28355)
if [[ $(LC_ALL=C $(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) != @(LLD|GNU\ ld)* ]]