summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-08-01 12:43:54 -0700
committerZac Medico <zmedico@gentoo.org>2020-08-01 13:25:37 -0700
commit1ffc00db7574a8dce54dc749b0599bcbdb7ed98f (patch)
treef2e73c964f8ca38859af21e7ea3b936df333c9f0 /app-emulation
parentprofiles/package.mask: mask media-sound/{exaile,jack} (diff)
downloadgentoo-1ffc00db7574a8dce54dc749b0599bcbdb7ed98f.tar.gz
gentoo-1ffc00db7574a8dce54dc749b0599bcbdb7ed98f.tar.bz2
gentoo-1ffc00db7574a8dce54dc749b0599bcbdb7ed98f.zip
app-emulation/buildah: Bump to version 1.14.10
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/buildah/Manifest1
-rw-r--r--app-emulation/buildah/buildah-1.14.10.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-emulation/buildah/Manifest b/app-emulation/buildah/Manifest
index 0dcb0f0f58d4..5a1bf9c1e880 100644
--- a/app-emulation/buildah/Manifest
+++ b/app-emulation/buildah/Manifest
@@ -1,3 +1,4 @@
+DIST buildah-1.14.10.tar.gz 10660400 BLAKE2B 5ee35cd90d652da8b30a01ae34aa73d68b2c531ac72017be87f6381717e1a59da6a9eccfcbab3b046a2a1a2b1c3e66e404ff6fab85a6d54a55320c6a6a405dca SHA512 5e9e1fd0f2c75b9846c1d457cfec3bf546b7e0683ea27607479c6ef5dacc8fd977ce57a885ef5ba14db0876ee47ffd8d3c54e349fe3375743a8bf70618c2c057
DIST buildah-1.14.5.tar.gz 11023227 BLAKE2B ebd6cecfc6fa4635ae662dddc722a350fd0b9c87c3d4d67f8010d5ea070270da4f4cd5759612b84d55ecd27b90904950b96471d75057bc6b7d45989312ebec8e SHA512 759d2ba26af43d6ff7ee891f88114a0cde6307439f7837343bfa6edba2473805f0f2e584264e8be01b9f0af07b1fd323243af5feeb9535ada4475ce53a980ff6
DIST buildah-1.14.6.tar.gz 11104320 BLAKE2B fa618e095523e853454170504aa2747d29e8bec16282eb4bdcf9d8ddeccceeb7ad706d0d127dc621ef0840136737b328c31d9b6b2f9bd1b734beb6d24a15bea3 SHA512 869addbd41c115ca92eab30133c76cd0d449184e95f3b64fa57ad84f50834e6f6189bd1a7e4871aba270b96bf69192ff00da7f0e086439c811c5093342ac14d2
DIST buildah-1.14.8.tar.gz 10660799 BLAKE2B b32375900c3509b88ae37366f1d2e2b593d0705cabf74c305bf0838f8e22ef9805e37b6bbe1a054d9fc3e48fa5c086fd0524362d570742eec846fb4b079c74d5 SHA512 8cc64d8262ffe3727f4c32051f4f3456ab0b54f221ce6d144a301b732170eb487dc356f4e056c804ca9806172e60920239b62800a0aac2dc5de83cd656ea97f3
diff --git a/app-emulation/buildah/buildah-1.14.10.ebuild b/app-emulation/buildah/buildah-1.14.10.ebuild
new file mode 100644
index 000000000000..7439b8eff82a
--- /dev/null
+++ b/app-emulation/buildah/buildah-1.14.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+
+KEYWORDS="~amd64"
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="selinux"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT=42ef63f0
+SRC_URI="https://github.com/containers/buildah/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+RDEPEND="app-crypt/gpgme:=
+ app-emulation/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+}
+
+src_compile() {
+ emake GIT_COMMIT=${GIT_COMMIT} all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin ${PN} imgtype
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}