summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-04-21 11:30:32 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-04-21 11:32:55 +0200
commit37851981078ad4f6194cfa07041a2bcfc26d6110 (patch)
tree388c5a6949955ccc9613fe8c762230a79a3b5aa4 /app-emulation/xen
parentkde-frameworks/plasma: Two 5.93 upstream backport requests (diff)
downloadgentoo-37851981078ad4f6194cfa07041a2bcfc26d6110.tar.gz
gentoo-37851981078ad4f6194cfa07041a2bcfc26d6110.tar.bz2
gentoo-37851981078ad4f6194cfa07041a2bcfc26d6110.zip
app-emulation/xen: enable CONFIG_CRASH_DEBUG on USE=debug
Bug: https://bugs.gentoo.org/838730 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/xen-4.16.0-r6.ebuild (renamed from app-emulation/xen/xen-4.16.0-r5.ebuild)9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-emulation/xen/xen-4.16.0-r5.ebuild b/app-emulation/xen/xen-4.16.0-r6.ebuild
index 994e9c774ce3..f57641df28d0 100644
--- a/app-emulation/xen/xen-4.16.0-r5.ebuild
+++ b/app-emulation/xen/xen-4.16.0-r6.ebuild
@@ -119,13 +119,16 @@ src_configure() {
touch gentoo-config || die
if use arm; then
- echo "CONFIG_EARLY_PRINTK=sun7i" > gentoo-config || die
+ echo "CONFIG_EARLY_PRINTK=sun7i" >> gentoo-config || die
fi
if use debug; then
- echo "CONFIG_DEBUG=y" > gentoo-config || die
+ cat <<-EOF >> gentoo-config || die
+ CONFIG_DEBUG=y
+ CONFIG_CRASH_DEBUG=y
+EOF
fi
if use flask; then
- echo "CONFIG_XSM=y" > gentoo-config || die
+ echo "CONFIG_XSM=y" >> gentoo-config || die
fi
emake KCONFIG_ALLCONFIG=gentoo-config alldefconfig