summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-01 12:22:27 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-01 22:14:00 -0500
commite38c1a2f33132a5016b0e887dec4b67839a69025 (patch)
tree632f780b068bcedcb40df2e4a26d7cc242e98b93 /app-emulation/wine-mono
parentapp-emulation/wine-mono: tidy metadata a bit (diff)
downloadgentoo-e38c1a2f33132a5016b0e887dec4b67839a69025.tar.gz
gentoo-e38c1a2f33132a5016b0e887dec4b67839a69025.tar.bz2
gentoo-e38c1a2f33132a5016b0e887dec4b67839a69025.zip
app-emulation/wine-mono: sync old 7.0.0+7.3.0 ebuilds with new
Except for keeping the old SRC_URI, no reason to replace tarballs. Doing this given (at least) 7.0.0 will be kept for a while. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-mono')
-rw-r--r--app-emulation/wine-mono/wine-mono-7.0.0.ebuild17
-rw-r--r--app-emulation/wine-mono/wine-mono-7.3.0.ebuild17
2 files changed, 14 insertions, 20 deletions
diff --git a/app-emulation/wine-mono/wine-mono-7.0.0.ebuild b/app-emulation/wine-mono/wine-mono-7.0.0.ebuild
index cbd75a5c9f9d..a1496c91940d 100644
--- a/app-emulation/wine-mono/wine-mono-7.0.0.ebuild
+++ b/app-emulation/wine-mono/wine-mono-7.0.0.ebuild
@@ -1,29 +1,26 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+DESCRIPTION="Replacement for the .NET runtime and class libraries in Wine"
HOMEPAGE="https://www.winehq.org/"
SRC_URI="
- !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
-"
+ !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )"
+S="${WORKDIR}"
LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
SLOT="${PV}"
KEYWORDS="amd64 x86"
IUSE="+shared"
-DEPEND="!!app-emulation/wine:0"
-
-S="${WORKDIR}"
-
src_install() {
insinto /usr/share/wine/mono
+
if use shared; then
- doins -r "${P}"
+ doins -r ${P}
else
- doins "${DISTDIR}/${P}-x86.msi"
+ doins "${DISTDIR}"/${P}-x86.msi
fi
}
diff --git a/app-emulation/wine-mono/wine-mono-7.3.0.ebuild b/app-emulation/wine-mono/wine-mono-7.3.0.ebuild
index 0836b039a90f..83761501a6f1 100644
--- a/app-emulation/wine-mono/wine-mono-7.3.0.ebuild
+++ b/app-emulation/wine-mono/wine-mono-7.3.0.ebuild
@@ -1,29 +1,26 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+DESCRIPTION="Replacement for the .NET runtime and class libraries in Wine"
HOMEPAGE="https://www.winehq.org/"
SRC_URI="
- !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
-"
+ !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )"
+S="${WORKDIR}"
LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
SLOT="${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+shared"
-DEPEND="!!app-emulation/wine:0"
-
-S="${WORKDIR}"
-
src_install() {
insinto /usr/share/wine/mono
+
if use shared; then
- doins -r "${P}"
+ doins -r ${P}
else
- doins "${DISTDIR}/${P}-x86.msi"
+ doins "${DISTDIR}"/${P}-x86.msi
fi
}