summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-26 06:00:17 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-26 06:10:32 -0400
commitbc948f21b9135ac5c4d1386bcaabff7bc00d7515 (patch)
treeb963911e74378206fecd3fe35a92e8e8c31687ce /app-emulation/wine-mono
parentkde-frameworks/kimageformats: drop 5.99.0-r2 (diff)
downloadgentoo-bc948f21b9135ac5c4d1386bcaabff7bc00d7515.tar.gz
gentoo-bc948f21b9135ac5c4d1386bcaabff7bc00d7515.tar.bz2
gentoo-bc948f21b9135ac5c4d1386bcaabff7bc00d7515.zip
app-emulation/wine-mono: add 7.4.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-mono')
-rw-r--r--app-emulation/wine-mono/Manifest2
-rw-r--r--app-emulation/wine-mono/wine-mono-7.4.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/Manifest b/app-emulation/wine-mono/Manifest
index c55ba7ae8ae1..eac48de26624 100644
--- a/app-emulation/wine-mono/Manifest
+++ b/app-emulation/wine-mono/Manifest
@@ -4,3 +4,5 @@ DIST wine-mono-7.3.0-x86.msi 86919680 BLAKE2B 917aa260ba7a012ed1e1565f8ed23225c8
DIST wine-mono-7.3.0-x86.tar.xz 43557004 BLAKE2B 919912faf97cf38b2fcc9813de4e035d907b0a00db78d2a251c1c43dab65ba44847ecbf494a15dba761d9ba8203855c1a6e5f5bbd07f20484c9948c3cfe4d3bc SHA512 c26dc21d0d462b3c79e778497815e33d26b5ab545eba0552b436f30d9b7aa340ccdef69fe0dcbf32c04330e6d0f813314646ded7d2d24e6f4746e4893adbbf7f
DIST wine-mono-7.3.1-x86.msi 86930432 BLAKE2B f43b605ab7b07a7b4d8d4675297af6e827e81b2b232c6991fb1f559a247c6b546490017dd4e1aab04aad664570cb90152ff872be61bb8e12a154ae2366dbb21c SHA512 dd9f3860c4b52edce44f51b27de2a3b4acc97271d661e41310b889fa378f502458739caaa548fff5e16ddba418d40d647528c151c0413519df54c38f9e237946
DIST wine-mono-7.3.1-x86.tar.xz 43216532 BLAKE2B bc00f41d2e9e88c0a687fad6bdd48e9a836f3d7369747602665691ca3e430c895655e9c5e9ef955a5cf45a96818b6858bc3cc93d90c3d7a49f8d8f4ff824d45a SHA512 a2c8d10d9b34fd7775eeddb6494b84f2f04e6a2f21d93940dc902434b189d43bdfdcd198baf8133cda8b17c2bc25ee84538e12a32027cdd66da9ab029eed6777
+DIST wine-mono-7.4.0-x86.msi 87334912 BLAKE2B c0b778f9db59d1a2917631f1d6ca1a1798972a6a42e27975da78f3a35b77018a99228d7d95e5640c57618533a6b01bf2252859e3e978e2aa8dbdc8cd62afcc28 SHA512 cf35513b368324487c387d4339e5b05a90c4825b25ea603140524b79e69786ccc20dfb898213a9548c0313c0b0e4b160acb88364e4b280dd6712d185d9e5ae57
+DIST wine-mono-7.4.0-x86.tar.xz 45404344 BLAKE2B 3a74106b9b3f21a88c2435f7988d66a54e08beea931a0ce0df6431c21add4ee2685bf9c9cb2404ee1a685736d61b1aee3cdd507130e5c5dddba7e506a2ff18bb SHA512 108cb5d969e84deeda3d2b11dba7cd73853fc3b088ecf2bcdb9bc5c5bbaaff03e72cd4f485d1935eda43cdd95b927886441be1d2204edeaee1ff1fea75735d22
diff --git a/app-emulation/wine-mono/wine-mono-7.4.0.ebuild b/app-emulation/wine-mono/wine-mono-7.4.0.ebuild
new file mode 100644
index 000000000000..f32c9e9a3a3f
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-7.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://www.winehq.org/"
+SRC_URI="
+ shared? ( https://github.com/madewokherd/wine-mono/releases/download/${P}/${P}-x86.tar.xz )
+ !shared? ( https://github.com/madewokherd/wine-mono/releases/download/${P}/${P}-x86.msi )"
+S="${WORKDIR}"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+src_install() {
+ insinto /usr/share/wine/mono
+
+ if use shared; then
+ doins -r ${P}
+ else
+ doins "${DISTDIR}"/${P}-x86.msi
+ fi
+}