summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/fuse-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/fuse-utils')
-rw-r--r--app-emulation/fuse-utils/Manifest1
-rw-r--r--app-emulation/fuse-utils/fuse-utils-1.1.1.ebuild38
-rw-r--r--app-emulation/fuse-utils/metadata.xml22
3 files changed, 61 insertions, 0 deletions
diff --git a/app-emulation/fuse-utils/Manifest b/app-emulation/fuse-utils/Manifest
new file mode 100644
index 000000000000..ca9063cdb24f
--- /dev/null
+++ b/app-emulation/fuse-utils/Manifest
@@ -0,0 +1 @@
+DIST fuse-utils-1.1.1.tar.gz 505766 SHA256 7c36c0b42805661a06c21aede3461ffc8ccdb5ce56fe232875bf86e79f77c93c SHA512 67a9cc6af97f213a43b5e557dfe800f823e914faae99d7c5b2ddfc52656ab89bac737df644b9aa32ac009bdc0740d2064ccc6de2643ecba9141787245f9657f9 WHIRLPOOL 6da43fbbacdc918ce1cd4b11b21499a7faf26afe5cd1cd46e4911594c515679f2b5f6640d0530b6f47f644bc16c0247b5df26c49893f2e656b7d878ec95ea394
diff --git a/app-emulation/fuse-utils/fuse-utils-1.1.1.ebuild b/app-emulation/fuse-utils/fuse-utils-1.1.1.ebuild
new file mode 100644
index 000000000000..054937d59d00
--- /dev/null
+++ b/app-emulation/fuse-utils/fuse-utils-1.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Utils for the Free Unix Spectrum Emulator by Philip Kendall"
+HOMEPAGE="http://fuse-emulator.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="audiofile gcrypt"
+
+RDEPEND="~app-emulation/libspectrum-1.1.1[gcrypt?]
+ audiofile? ( >=media-libs/audiofile-0.2.3 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with audiofile ) \
+ $(use_with gcrypt libgcrypt) \
+ || die "Configure failed!"
+}
+
+src_compile() {
+ emake || die "Make failed!"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS ChangeLog README
+ doman man/*.1
+}
diff --git a/app-emulation/fuse-utils/metadata.xml b/app-emulation/fuse-utils/metadata.xml
new file mode 100644
index 000000000000..b5eea7296dd7
--- /dev/null
+++ b/app-emulation/fuse-utils/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ <name>Jesus Rivero</name>
+ <description>Proxy Maintainer. Please CC on bugs.</description>
+ </maintainer>
+ <maintainer>
+ <email>jmfo1982@yahoo.es</email>
+ <description>Proxied Maintainer. Please assign on bugs.</description>
+ <name>José Manuel Ferrer Ortiz</name>
+ </maintainer>
+ <use>
+ <flag name="gcrypt">Use <pkg>dev-libs/libgcrypt</pkg> for low-level crypto of some
+ features, including logfiles.</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">fuse-emulator</remote-id>
+ </upstream>
+</pkgmetadata>