summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-03-28 15:20:07 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-03-28 15:20:07 +0100
commit5587b321c30f0fe46eac57d4c8140f916cdf9054 (patch)
tree55252410ddd282f0edcbdcd7f0834b6a51820158 /app-emulation/containerd
parentsys-cluster/kube-apiserver: Version bump to 1.13.5 (diff)
downloadgentoo-5587b321c30f0fe46eac57d4c8140f916cdf9054.tar.gz
gentoo-5587b321c30f0fe46eac57d4c8140f916cdf9054.tar.bz2
gentoo-5587b321c30f0fe46eac57d4c8140f916cdf9054.zip
app-emulation/containerd: Version bump to 1.2.5
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-1.2.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index c249575b87a0..9eeb839fc7a1 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -3,3 +3,4 @@ DIST containerd-1.1.4.tar.gz 5328134 BLAKE2B cb69f9bd80bc279ae2bd85c75152dacdbdf
DIST containerd-1.2.2.tar.gz 4607013 BLAKE2B aca366f23cb24ddd0363333e5a4ab0fc833f917c7f1f01d56fd22bdb4bc6721f077e5ba411db6faecc4152b8f047af5da95283029f6e66dadad49c7296b82c89 SHA512 0fdd8799c5afb75074b6f00d5191e983ff570b323242665055c73b2e7a6bdd74a745e287f4f7b675dde26e8bf083c144104151e794ad24d2a8f6f39ae2ee6fff
DIST containerd-1.2.3.tar.gz 4612104 BLAKE2B 9b975bea8f848c667c44e3b597fd16889796b5b482b2ea528505db9089da46da8d4e655ba8e77f6e205825be193984124b315231b9bda8bb75dc28d3500f9897 SHA512 01c6e196ddaebfffd069aca87c669acae3923bc9b25f3a59070a6fdbe28661afd4e548b9bb6a4faec3d3d3a937f36eacd7c179986d04f83428cff439e41b1e0d
DIST containerd-1.2.4.tar.gz 4866424 BLAKE2B bd06d2df49fa426b0bb6fdbcb091215e34a7a0c30eb97c84887451dbfc126eef89eea714bd725fdf038eb7a2c4416237a27fc12730a8f241c27a12d47bfaee43 SHA512 8a4e5064b2c1e14d39d9943f445ae18e4653f73bd3bb90f7efe558b9ffd4345db4b308362103dbfbede716eae8b547c1cec3d93962acb0a2ff34d66e4fce0d80
+DIST containerd-1.2.5.tar.gz 4871876 BLAKE2B f8652d00b4338d0f4a1d77d452a46c316cc38b57f2df64fcfcef463f10d030f363b54f1a12c4cb32d9010872c688a75ebc1d481439dc3eb84aab193fc80c9bc0 SHA512 b249d5bfc0c1f884ecc1ad4544f9440405450c31f11e80ac094bfddb7a6660e950116114e563d7655e07f888f2ff62f4476f2b178f4e0e2acbbb9fb84a243b25
diff --git a/app-emulation/containerd/containerd-1.2.5.ebuild b/app-emulation/containerd/containerd-1.2.5.ebuild
new file mode 100644
index 000000000000..f33a2808fa24
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.2.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_rc/-rc.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT="bb71b10fd8f58240ca47fbb579b9d1028eea7c84"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor +btrfs +cri hardened +seccomp"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )"
+RDEPEND=">=app-emulation/runc-1.0.0_rc5
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ -e "s/-s -w//" \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex btrfs "" "no_btrfs") $(usex cri "" "no_cri") $(usex seccomp "seccomp" "") $(usex apparmor "apparmor" "") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') BUILDTAGS="${options[@]}" emake
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ keepdir /var/lib/containerd
+ dobin bin/*
+}