summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-20 18:26:24 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-20 18:27:00 +0200
commited9f8a69d48d123f49fb9799050d3a811eb4cf6a (patch)
tree40aba52734b5c65c22bfe44b10d2294c471db399 /app-emacs
parentapp-emacs/embark-consult: bump to 0.23 (diff)
downloadgentoo-ed9f8a69d48d123f49fb9799050d3a811eb4cf6a.tar.gz
gentoo-ed9f8a69d48d123f49fb9799050d3a811eb4cf6a.tar.bz2
gentoo-ed9f8a69d48d123f49fb9799050d3a811eb4cf6a.zip
app-emacs/modus-themes: bump to 4.3.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/modus-themes/Manifest1
-rw-r--r--app-emacs/modus-themes/modus-themes-4.3.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/modus-themes/Manifest b/app-emacs/modus-themes/Manifest
index 618fe851a641..420dfcaf2c63 100644
--- a/app-emacs/modus-themes/Manifest
+++ b/app-emacs/modus-themes/Manifest
@@ -1 +1,2 @@
DIST modus-themes-4.2.0.tar.gz 323621 BLAKE2B 7e5e19a294d802bcccfa6f1ca5b53b52ad584a634271d72ea63a5a061678b66149111e05dadc6d7dbb581a5c9dfd26a75f36abac3d87948324709474c204ec1f SHA512 a2484a9d7d42cfe0f74379f1f5bda02bc31a2fac16836644a3a6c6b568a6ee0e2d4804950732f2a132bef330bb7c0e34058256036f81afc27301262ffda79fae
+DIST modus-themes-4.3.0.tar.gz 329115 BLAKE2B 343070beb66fece35000abe4ae2d4b38c4e06f40a79ed6b12586ed37d39d4c9b67f930869ea8dab51bba84936ed55a8280ea838c4f3be235f95b28d9ec89ffc2 SHA512 3fd24e1b94ec6f3391568f3b92c9224372729494d7edd3ca51167f1a410038f046aaa7fcc8bda8a46ac0a1da5f0509fa9c8dbe49ddfb1aa26b64dcc11ee7ee77
diff --git a/app-emacs/modus-themes/modus-themes-4.3.0.ebuild b/app-emacs/modus-themes/modus-themes-4.3.0.ebuild
new file mode 100644
index 000000000000..b7a947039a4b
--- /dev/null
+++ b/app-emacs/modus-themes/modus-themes-4.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Convert symbol names between different naming conventions"
+HOMEPAGE="https://github.com/protesilaos/modus-themes/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}