summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-23 12:57:34 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-23 16:05:33 +0100
commitd2f5cdc56298c2fa0587367395cd55017958c491 (patch)
treeeb079d6eb41afa5261311e9573fed967e51a22b0 /app-emacs
parentapp-emacs/racket-mode: bump to 1_p20221216 (diff)
downloadgentoo-d2f5cdc56298c2fa0587367395cd55017958c491.tar.gz
gentoo-d2f5cdc56298c2fa0587367395cd55017958c491.tar.bz2
gentoo-d2f5cdc56298c2fa0587367395cd55017958c491.zip
app-emacs/vertico: bump to 1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/vertico/Manifest1
-rw-r--r--app-emacs/vertico/vertico-1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/vertico/Manifest b/app-emacs/vertico/Manifest
index 902ec0774b10..f47518105087 100644
--- a/app-emacs/vertico/Manifest
+++ b/app-emacs/vertico/Manifest
@@ -1,3 +1,4 @@
DIST vertico-0.27.tar.gz 43417 BLAKE2B be9fcd53c836e16f6ee3380ed8f727fbc62153a87a759dee7091b959f3ad0a940a6c1fe176a2073db153ae855b42a64ee92f57e7f3be4538c2f8a13606443d06 SHA512 cce90065473cf8440567b591544bf74af71752e476b667d7bc7d77bb83c8d43e38f2170f5e66f4723dfe29e6228d4933be2cb0d899cb8b56843a6a1ecb07f6a3
DIST vertico-0.28.tar.gz 43472 BLAKE2B 4c2771104960ee95ac7dffebecdf30ddfcc42bb91377dbbf27f245e9f93eb392dfa16a9fdd45f34ef739b4f9364cdb3d5c9dca9dd2a111a0008b726bc31df117 SHA512 3844f16184056210cadc755e52d5886c9c6ed0b00278d5c1b0d30e2d13dd8b63215026305e62d69873aaea720aadaeb772b29161d98d2e080b302565bd1f1d4a
DIST vertico-0.29.tar.gz 43682 BLAKE2B fef1ae786c823d7180f1c2d312a5961309d934145029933cc05e09839120bb2f4fcd1dbfad2194bb8613badb49966d1f69eb658397e4e2346ccc46fb228136ff SHA512 6af726ee916090247d003f552470dea6a2348c3ca382e030fe4c3de777c3414ed00a50aa5cdec17de7e59ebd44f5d88d842a284b38be7f9edca9220a1b240da0
+DIST vertico-1.0.tar.gz 43930 BLAKE2B 7418566d03c86c95aeb1969db19359628f04930413b17aaa2113836ee90368bb6df26c6af16a530a2977f3834b56565bbcd304ce362b6387baf9cc812c8b2982 SHA512 ad4e92b1edc5897f37b5ecc0c2f3291cf775afca14a33f1db17878f0560a4a1230513b833b1222f97b92f8711d2178bc30c6ccb55c8d22593f29b01717fd8968
diff --git a/app-emacs/vertico/vertico-1.0.ebuild b/app-emacs/vertico/vertico-1.0.ebuild
new file mode 100644
index 000000000000..eec14ff439d5
--- /dev/null
+++ b/app-emacs/vertico/vertico-1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico"
+SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}