summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-16 02:24:55 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-16 02:24:55 +0200
commit911bfd050890976ce77269c4991b7782f0c1acb9 (patch)
treef750311254a41ed48a76e1e41741812362932a74 /app-emacs/powershell
parentapp-emacs/dockerfile-mode: new package; add version 1.6 (diff)
downloadgentoo-911bfd050890976ce77269c4991b7782f0c1acb9.tar.gz
gentoo-911bfd050890976ce77269c4991b7782f0c1acb9.tar.bz2
gentoo-911bfd050890976ce77269c4991b7782f0c1acb9.zip
app-emacs/powershell: new package; add version 0.3_pre20220402
2022.04.02 snapshot ...before 0.3 release Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/powershell')
-rw-r--r--app-emacs/powershell/Manifest1
-rw-r--r--app-emacs/powershell/files/50powershell-gentoo.el6
-rw-r--r--app-emacs/powershell/metadata.xml14
-rw-r--r--app-emacs/powershell/powershell-0.3_pre20220402.ebuild21
4 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/powershell/Manifest b/app-emacs/powershell/Manifest
new file mode 100644
index 000000000000..4b06bdf7f5e2
--- /dev/null
+++ b/app-emacs/powershell/Manifest
@@ -0,0 +1 @@
+DIST powershell-0.3_pre20220402.tar.gz 17009 BLAKE2B c369993bc4ac0e681dde514c4303f6c131198e77f6aa3b293ecedefa552e8f2b94e8ab77978ff2f8d999a4b620fa4e013023a283e0a2c30f6578428bc54fe52d SHA512 2d38f1a968119a2022e1f3eceb8150947559e5e7943d184fec3b8075cc2dc8d97b5a897bc1ac97b14d69d9424b72ca20f01d24589403936b1ca2bc7becc2ea0f
diff --git a/app-emacs/powershell/files/50powershell-gentoo.el b/app-emacs/powershell/files/50powershell-gentoo.el
new file mode 100644
index 000000000000..e97cc3554edc
--- /dev/null
+++ b/app-emacs/powershell/files/50powershell-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'powershell "powershell"
+ "Run an inferior PowerShell." t)
+(autoload 'powershell-mode "powershell"
+ "Major mode for editing PowerShell scripts." t)
+(add-to-list 'auto-mode-alist '("\\.ps[dm]?1\\'" . powershell-mode))
diff --git a/app-emacs/powershell/metadata.xml b/app-emacs/powershell/metadata.xml
new file mode 100644
index 000000000000..ed7371a06f5f
--- /dev/null
+++ b/app-emacs/powershell/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <bugs-to>https://github.com/jschaf/powershell.el/issues/</bugs-to>
+ <remote-id type="github">jschaf/powershell.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/powershell/powershell-0.3_pre20220402.ebuild b/app-emacs/powershell/powershell-0.3_pre20220402.ebuild
new file mode 100644
index 000000000000..6d53582ddb59
--- /dev/null
+++ b/app-emacs/powershell/powershell-0.3_pre20220402.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=77b27faf8a292f1dc9f54c872241dc53b6791bf1
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs mode for editing and running PowerShell code"
+HOMEPAGE="https://github.com/jschaf/powershell.el/"
+SRC_URI="https://github.com/jschaf/${PN}.el/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"