summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2023-10-04 12:14:57 +0200
committerMatthias Maier <tamiko@gentoo.org>2023-10-04 12:46:47 -0500
commit3fa94b0e3f9da3df733206154ad2a538b0904265 (patch)
treee3389d0c6e3ebf6dbd4f9e8f42f550228a7d4db0 /app-emacs/nxml-libvirt-schemas
parentdev-perl/Sys-Virt: Add 9.7.0 (diff)
downloadgentoo-3fa94b0e3f9da3df733206154ad2a538b0904265.tar.gz
gentoo-3fa94b0e3f9da3df733206154ad2a538b0904265.tar.bz2
gentoo-3fa94b0e3f9da3df733206154ad2a538b0904265.zip
app-emacs/nxml-libvirt-schemas: Add 9.8.0
Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Signed-off-by: Matthias Maier <tamiko@gentoo.org> Acked-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/nxml-libvirt-schemas')
-rw-r--r--app-emacs/nxml-libvirt-schemas/Manifest1
-rw-r--r--app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-9.8.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/nxml-libvirt-schemas/Manifest b/app-emacs/nxml-libvirt-schemas/Manifest
index 13b044a62827..9c904ad1f0cf 100644
--- a/app-emacs/nxml-libvirt-schemas/Manifest
+++ b/app-emacs/nxml-libvirt-schemas/Manifest
@@ -3,3 +3,4 @@ DIST libvirt-8.9.0.tar.xz 8946352 BLAKE2B 537b6badb6171110e99561613fb13181449911
DIST libvirt-9.2.0.tar.xz 9182060 BLAKE2B 8b9ffc86e088de6b1ec6b38b649bded3abbbce8eec9c1ba19f31e73ecd7ee13a5c521a6e1fd8da9f308158dd05c87171aa443cd00f0c87a73f205e3d57a22567 SHA512 9afd4fcccb9ef39c1ed50eb0db94cd8b06cc5b60041cdb9aa5fe7b27e5ab11855f4b538d6868413725d603dc1a6090e0983207137dcd43ed2bbcfbeb6fc69c58
DIST libvirt-9.3.0.tar.xz 9246292 BLAKE2B 6e47a70ec247b37c1958e324d5bf7ebcbff6aca5a7a9860f437ebe6a969d569a449d3dd5720081ad27926f445bcbe10089cb3b1d27960decc6239306f82259f9 SHA512 b9349dcd7798c76d75bb20afad67d6e676758cb201acaf7aed5109f0e91422b2bcca964a2f19aa8dc4fd0eca2923902474e16e3839bf8b15aca827028e88ddb7
DIST libvirt-9.6.0.tar.xz 9282400 BLAKE2B a58f2dea7a3051bb7a69678bd1e1dac9123892b2ca7ee6b204bda1a0a3c8fd2d210b2295b300bb88fab86dfddb3d7472d495ff4c10af84bb53b7662190cf17c4 SHA512 654d22cc71926715e103313f01a4f117a19dfcf3087ffe714cf2114dbc88e42ac33cc6c100c61e60f76f13468ff5f369b157748ca6cd69c4d504d4de6b6e44b4
+DIST libvirt-9.8.0.tar.xz 9307064 BLAKE2B aae47e8d4eeaf97532a0356de23ed5a9eea71b369d025eda95b5fd74576779eb4b843d05df6c87b79a14f218c341953749e319ee7244846a2db410a74a746880 SHA512 0118725073de33eec3fa3e4616d3154707f9828fdb9ec973f503fe68f18eab72b9704da660f281152630ddc95e605c786673af9d23dc9bdfc0108422e0efbd41
diff --git a/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-9.8.0.ebuild b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-9.8.0.ebuild
new file mode 100644
index 000000000000..cdedf3214219
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-9.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Packages which get releases together:
+# app-emacs/nxml-libvirt-schemas
+# dev-python/libvirt-python
+# dev-perl/Sys-Virt
+# app-emulation/libvirt
+# Please bump them together!
+
+inherit elisp
+
+MY_P="libvirt-${PV}"
+DESCRIPTION="Extension for nxml-mode with libvirt schemas"
+HOMEPAGE="https://www.libvirt.org/"
+SRC_URI="https://libvirt.org/sources/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P%-rc*}/src/conf/schemas"
+
+# This is the license of the package, but the schema files are
+# provided without license, maybe it's bad.
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+BDEPEND="app-text/trang"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() {
+ emake -f - <<'EOF'
+all: $(patsubst %.rng,%.rnc,$(wildcard *.rng))
+%.rnc: %.rng
+ trang -I rng -O rnc $< $@
+EOF
+}
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins "${FILESDIR}"/schemas.xml *.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}