summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-02 13:29:32 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-02 16:11:30 +0200
commit087f29e1dd9d0478874d08b281aa1330cdae180f (patch)
tree5fdc1b28389c7bfecd29c02c02fef4ffaa58e562 /app-emacs/howm
parentapp-emacs/devil: drop old 0.4.0 (diff)
downloadgentoo-087f29e1dd9d0478874d08b281aa1330cdae180f.tar.gz
gentoo-087f29e1dd9d0478874d08b281aa1330cdae180f.tar.bz2
gentoo-087f29e1dd9d0478874d08b281aa1330cdae180f.zip
app-emacs/howm: bump to 1.5.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/howm')
-rw-r--r--app-emacs/howm/Manifest1
-rw-r--r--app-emacs/howm/howm-1.5.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/howm/Manifest b/app-emacs/howm/Manifest
index 594129691566..2f632f550388 100644
--- a/app-emacs/howm/Manifest
+++ b/app-emacs/howm/Manifest
@@ -1,2 +1,3 @@
DIST howm-1.4.5.tar.gz 565221 BLAKE2B a28e98e9b955c6172c7b9e51d8f157e22e87846cb2a2955d956f434c2a36fad7e0692c951ef3d37f57363d500d118c2eeaad55276656a8e543b72b8276317fa4 SHA512 b448bf8caeaf21bf1980862ed12541bd793369494a3e321bc5b77bb99ef63cc5ed2f70c54eaa60b427489e9b3fa9b0037d5cbe06449f87af924f245b7f8f2615
DIST howm-1.4.8.tar.gz 566903 BLAKE2B 0c4dee89147acb40051be18833ec4027bebc81102af2571e15fc06a9c6cefd3d1f0334008550321ad81ec28b44151bc9bc5ab4db8ad376cc4726fd571a77076d SHA512 e95a7e3287cd1cdb1c51d99b00627f8824e1c2a470a1a986910b8e79cd79234a0032c9d92dd5009bb6c09911c1d8848cb0fc585ecce8f5d1020cd5bbe2d36aa8
+DIST howm-1.5.0.tar.gz 569867 BLAKE2B 68e4be1a808bea2f52167a9bea954e9d4036a6910525b01433e91e4f6ffbb9c0ec918d50a5b97544d88da651c905dcf56356dc6b8968b77522c0df2f8add5b2d SHA512 104be07b5167ce05dc794a4029c1ee35f8471f9fa406be3eba3565362a1685b9859b73de422ad43339db9f0f89245aa7a3838129996405d5b3f6fd633c3303bc
diff --git a/app-emacs/howm/howm-1.5.0.ebuild b/app-emacs/howm/howm-1.5.0.ebuild
new file mode 100644
index 000000000000..1e3fec90e3d5
--- /dev/null
+++ b/app-emacs/howm/howm-1.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Note-taking tool on Emacs"
+HOMEPAGE="https://howm.sourceforge.jp/"
+SRC_URI="http://howm.sourceforge.jp/a/${P}.tar.gz"
+
+LICENSE="GPL-1+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ --with-emacs \
+ --with-lispdir="${SITELISP}" \
+ EMACS="${EMACS} --no-site-file"
+}
+
+src_compile() {
+ emake -j1 EMACS="${EMACS} --no-site-file" </dev/null
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install </dev/null
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ChangeLog
+}