summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-26 17:34:37 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-07 12:37:40 +0100
commitbeea6ed74eb77f3f16cb60e441cf51afd08ccc71 (patch)
tree9008f7111c9dc80a0eb864744149e0b2eebbe752 /app-editors
parentapp-admin/sysstat: [QA] Remove invalid USE=lto (diff)
downloadgentoo-beea6ed74eb77f3f16cb60e441cf51afd08ccc71.tar.gz
gentoo-beea6ed74eb77f3f16cb60e441cf51afd08ccc71.tar.bz2
gentoo-beea6ed74eb77f3f16cb60e441cf51afd08ccc71.zip
app-editors/neovim: [QA] Remove invalid USE=lto
USE=lto in this package only appends -flto flag. This is not a valid use of the USE flag, as lto in Gentoo is enabled via setting flags manually. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/neovim-0.9.2.ebuild12
-rw-r--r--app-editors/neovim/neovim-0.9.3.ebuild12
-rw-r--r--app-editors/neovim/neovim-0.9.4.ebuild12
-rw-r--r--app-editors/neovim/neovim-0.9.5.ebuild5
-rw-r--r--app-editors/neovim/neovim-9999.ebuild13
5 files changed, 19 insertions, 35 deletions
diff --git a/app-editors/neovim/neovim-0.9.2.ebuild b/app-editors/neovim/neovim-0.9.2.ebuild
index 5e384cea9321..515443d061d5 100644
--- a/app-editors/neovim/neovim-0.9.2.ebuild
+++ b/app-editors/neovim/neovim-0.9.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,7 @@ fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+lto +nvimpager test"
+IUSE="+nvimpager test"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
@@ -82,14 +82,10 @@ src_prepare() {
}
src_configure() {
- # Upstream default to LTO on non-debug builds
- # Let's expose it as a USE flag because upstream
- # have preferences for how we should use LTO
- # if we want it on (not just -flto)
- # ... but allow turning it off.
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
- -DENABLE_LTO=$(usex lto)
+ # appends -flto
+ -DENABLE_LTO=OFF
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
-DLUA_PRG="${ELUA}"
)
diff --git a/app-editors/neovim/neovim-0.9.3.ebuild b/app-editors/neovim/neovim-0.9.3.ebuild
index ec45d50f6dd1..3b0381d9c4a9 100644
--- a/app-editors/neovim/neovim-0.9.3.ebuild
+++ b/app-editors/neovim/neovim-0.9.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,7 @@ fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+lto +nvimpager test"
+IUSE="+nvimpager test"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
@@ -82,14 +82,10 @@ src_prepare() {
}
src_configure() {
- # Upstream default to LTO on non-debug builds
- # Let's expose it as a USE flag because upstream
- # have preferences for how we should use LTO
- # if we want it on (not just -flto)
- # ... but allow turning it off.
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
- -DENABLE_LTO=$(usex lto)
+ # appends -flto
+ -DENABLE_LTO=OFF
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
-DLUA_PRG="${ELUA}"
)
diff --git a/app-editors/neovim/neovim-0.9.4.ebuild b/app-editors/neovim/neovim-0.9.4.ebuild
index f2763ef22dda..c1f5cc554988 100644
--- a/app-editors/neovim/neovim-0.9.4.ebuild
+++ b/app-editors/neovim/neovim-0.9.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,7 @@ fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+lto +nvimpager test"
+IUSE="+nvimpager test"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
@@ -82,14 +82,10 @@ src_prepare() {
}
src_configure() {
- # Upstream default to LTO on non-debug builds
- # Let's expose it as a USE flag because upstream
- # have preferences for how we should use LTO
- # if we want it on (not just -flto)
- # ... but allow turning it off.
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
- -DENABLE_LTO=$(usex lto)
+ # appends -flto
+ -DENABLE_LTO=OFF
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
-DLUA_PRG="${ELUA}"
)
diff --git a/app-editors/neovim/neovim-0.9.5.ebuild b/app-editors/neovim/neovim-0.9.5.ebuild
index 09f8192d137b..5c8fb769b9f3 100644
--- a/app-editors/neovim/neovim-0.9.5.ebuild
+++ b/app-editors/neovim/neovim-0.9.5.ebuild
@@ -21,7 +21,7 @@ fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+lto +nvimpager test"
+IUSE="+nvimpager test"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
@@ -89,7 +89,8 @@ src_configure() {
# ... but allow turning it off.
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
- -DENABLE_LTO=$(usex lto)
+ # appends -flto
+ -DENABLE_LTO=OFF
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
-DLUA_PRG="${ELUA}"
)
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 41b10f5d0a92..1aa5eaa0db8b 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,7 @@ fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+lto +nvimpager test"
+IUSE="+nvimpager test"
# Upstream say the test library needs LuaJIT
# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
@@ -81,15 +81,10 @@ src_prepare() {
}
src_configure() {
- ln -s "${BROOT}"/usr/bin/luajit "${BUILD_DIR}"/luajit || die
- # Upstream default to LTO on non-debug builds
- # Let's expose it as a USE flag because upstream
- # have preferences for how we should use LTO
- # if we want it on (not just -flto)
- # ... but allow turning it off.
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
- -DENABLE_LTO=$(usex lto)
+ # appends -flto
+ -DENABLE_LTO=OFF
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
-DLUA_PRG="${ELUA}"
)