summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-21 13:13:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-21 13:40:45 +0200
commit024707871858d51be4b1e24ee6b0fc52c0e0c16a (patch)
treeb667a55c3bf0e0c83bf7ea4df3fdf414a78417ab /app-editors
parentdev-python/trove-classifiers: Stabilize 2024.10.16 ALLARCHES, #941923 (diff)
downloadgentoo-024707871858d51be4b1e24ee6b0fc52c0e0c16a.tar.gz
gentoo-024707871858d51be4b1e24ee6b0fc52c0e0c16a.tar.bz2
gentoo-024707871858d51be4b1e24ee6b0fc52c0e0c16a.zip
app-editors/mousepad: Bump to 0.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mousepad/Manifest1
-rw-r--r--app-editors/mousepad/mousepad-0.6.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index c1b0861653a8..7a5200a83b2d 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1 +1,2 @@
DIST mousepad-0.6.2.tar.bz2 1402314 BLAKE2B c783ec58317ca3c0eaa0023ade3043f4aa4f020a12c0258fe0cf1e2303aa07dfbc67b9aa0178ca9282da98754103fda6c90ba034fa4057dd855b400c0d371085 SHA512 086f60f6f405290ed76366f4c5195e9c8f9c5058d1892200a73e48d6378428efe47f2038e3eddb81186e22dd87d57580559a556b1b22f202b6f056c7f90b64ea
+DIST mousepad-0.6.3.tar.bz2 1428583 BLAKE2B 73a0eb0cfecaa88c6d3508034561206ff1a24139bbdea4cb677ec79de30a59386cf7beb7fd540d31c0a3ec4804ba2001b13470baf0bbec19dc4cf1cc315479ee SHA512 a47e9c0d5b039444ee455e80d0ab4642d5c29d6e5632ec4fccfcef061b4bf40a1709ea73b092b02e915e1796d1593ede68e59b9fe373e127302d34f82c9beae3
diff --git a/app-editors/mousepad/mousepad-0.6.3.ebuild b/app-editors/mousepad/mousepad-0.6.3.ebuild
new file mode 100644
index 000000000000..9ee8b38d6546
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.6.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/mousepad/start
+ https://gitlab.xfce.org/apps/mousepad/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="policykit spell +shortcuts"
+
+DEPEND="
+ >=dev-libs/glib-2.56.2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0.0:4
+ policykit? ( sys-auth/polkit )
+ spell? ( app-text/gspell )
+ shortcuts? ( >=xfce-base/libxfce4ui-4.17.5:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --enable-gtksourceview4
+ $(use_enable policykit polkit)
+ $(use_enable spell plugin-gspell)
+ $(use_enable shortcuts plugin-shortcuts)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}