summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/znotes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/znotes')
-rw-r--r--app-editors/znotes/Manifest1
-rw-r--r--app-editors/znotes/files/znotes-0.4.5-gcc-4.7.patch24
-rw-r--r--app-editors/znotes/metadata.xml10
-rw-r--r--app-editors/znotes/znotes-0.4.5.ebuild28
4 files changed, 63 insertions, 0 deletions
diff --git a/app-editors/znotes/Manifest b/app-editors/znotes/Manifest
new file mode 100644
index 000000000000..7b4fe9c2fe81
--- /dev/null
+++ b/app-editors/znotes/Manifest
@@ -0,0 +1 @@
+DIST znotes-0.4.5.tar.gz 171884 SHA256 ac692253e74bda8f989db40042c26b6db2bb60a5f9c30cdbfcd824af0de1c5b2 SHA512 a7d9c149bbe80b83eff75eeec9644f9e648911c9cc5d6c83507b2d82199b7a2d1148665d6b650eb022dab1b34bbab96d52a0c27ac04525c30e4840049565e240 WHIRLPOOL 02acbe2f712b9ec5e4e9ca383aa8f6c04c98ba1a6bec73572c4656b2d1bb3faca4c8f39021e2e8c68d57495b582e7b29eaf6bdc3878c947d6cd5aadd37806798
diff --git a/app-editors/znotes/files/znotes-0.4.5-gcc-4.7.patch b/app-editors/znotes/files/znotes-0.4.5-gcc-4.7.patch
new file mode 100644
index 000000000000..ae8c4eca7b8e
--- /dev/null
+++ b/app-editors/znotes/files/znotes-0.4.5-gcc-4.7.patch
@@ -0,0 +1,24 @@
+From 9cb09430444e36415e887317525a24e542e135fb Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Fri, 31 Aug 2012 02:15:30 +1000
+Subject: [PATCH] Fix build with GCC 4.7.
+
+---
+ single_inst/qtlocalpeer.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/single_inst/qtlocalpeer.cpp b/single_inst/qtlocalpeer.cpp
+index 6d7c24f..f9663c9 100644
+--- a/single_inst/qtlocalpeer.cpp
++++ b/single_inst/qtlocalpeer.cpp
+@@ -50,6 +50,7 @@ static PProcessIdToSessionId pProcessIdToSessionId = 0;
+ #endif
+ #if defined(Q_OS_UNIX)
+ #include <time.h>
++#include <unistd.h>
+ #endif
+
+ namespace QtLP_Private {
+--
+1.7.12
+
diff --git a/app-editors/znotes/metadata.xml b/app-editors/znotes/metadata.xml
new file mode 100644
index 000000000000..1fc9dad40de4
--- /dev/null
+++ b/app-editors/znotes/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="sourceforge">znotes</remote-id>
+ <remote-id type="github">proton/zNotes</remote-id>
+ <bugs-to>https://github.com/proton/zNotes/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-editors/znotes/znotes-0.4.5.ebuild b/app-editors/znotes/znotes-0.4.5.ebuild
new file mode 100644
index 000000000000..40ec5b607b75
--- /dev/null
+++ b/app-editors/znotes/znotes-0.4.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit qt4-r2
+
+DESCRIPTION="Simple Notes"
+HOMEPAGE="http://znotes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGELOG THANKS"
+
+PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )
+
+src_configure() {
+ lrelease znotes.pro || die "lrelease failed"
+ qt4-r2_src_configure
+}