summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDongsu Park <dpark@linux.microsoft.com>2021-11-29 16:59:03 +0100
committerSam James <sam@gentoo.org>2021-12-01 17:06:55 +0000
commitfc72192754c8a1ff9014fd739a2d07056b25ed1e (patch)
treeb28bc19b45157ec075c662b9aefbe9db29603229 /app-editors/vim/vim-9999.ebuild
parentmedia-libs/osl: stabilize 1.11.16.0 for amd64 (diff)
downloadgentoo-fc72192754c8a1ff9014fd739a2d07056b25ed1e.tar.gz
gentoo-fc72192754c8a1ff9014fd739a2d07056b25ed1e.tar.bz2
gentoo-fc72192754c8a1ff9014fd739a2d07056b25ed1e.zip
app-editors/vim: remove warning due to missing defaults.vim
vim >= 8.2.3428 prints out a warning on missing file, when it is built with USE="minimal" and `app-editors/vim-core` is not installed. ``` $ vim E1187: Failed to source defaults.vim Press ENTER or type command to continue ``` To remove warning, explicitly install /usr/share/vim/vim82/defaults.vim. Closes: https://bugs.gentoo.org/820356 Signed-off-by: Dongsu Park <dpark@linux.microsoft.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/vim/vim-9999.ebuild')
-rw-r--r--app-editors/vim/vim-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index bdfd543c08a4..3ce917bf8851 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -318,6 +318,12 @@ src_install() {
fperms a+x ${vimfiles}/macros/manpager.sh
fi
+ # Fix an issue of missing defaults.vim when USE=minimal.
+ if use minimal ; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
+
domenu runtime/vim.desktop
newbashcomp "${FILESDIR}"/${PN}-completion ${PN}