summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZurab Kvachadze <zurabid2016@gmail.com>2024-05-05 00:25:49 +0300
committerYixun Lan <dlan@gentoo.org>2024-06-06 16:04:45 +0000
commitdfe0f6835c24aa514c8f602fb5267c0f5c9aaa1a (patch)
tree47de502c10a12eef324222d2a7426f3785a71851 /app-dicts
parentnet-im/telegram-desktop-bin: drop old (diff)
downloadgentoo-dfe0f6835c24aa514c8f602fb5267c0f5c9aaa1a.tar.gz
gentoo-dfe0f6835c24aa514c8f602fb5267c0f5c9aaa1a.tar.bz2
gentoo-dfe0f6835c24aa514c8f602fb5267c0f5c9aaa1a.zip
app-dicts/myspell-en: add 20240601, remove redundant l10n_en USE flag
In the previous versions of app-dicts/myspell-en there was a IUSE=l10n_en, which unconditionally enabled all the English varieties. This USE flag is redundant, since the purpose it serves can be as easily achieved by switching the individual USE flags on. Hence, the IUSE=l10n_en is removed. All other English varieties' USE flags are set to be enabled by default, to avoid the need to manually set them in order to mimic the old behaviour (which might have been required in the most cases). Closes: https://bugs.gentoo.org/481618 Closes: https://github.com/gentoo/gentoo/pull/36552 Signed-off-by: Zurab Kvachadze <zurabid2016@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-en/Manifest1
-rw-r--r--app-dicts/myspell-en/myspell-en-20240601.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index 9919033d58d9..b513fa6b4acc 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -1,2 +1,3 @@
DIST dict-en-20240201_lo.oxt 6105836 BLAKE2B 2978b36dfea07570b8be255c021e8f6cf9113f3ea342db0cc25d52e58a406f75015fdc5961556594756fde30293c21bcbf17c00b49e962e5a4f558be3f17b42c SHA512 92098925935ec23a3058db4a136e37f6dc3c24f0901de45bfd84e19efb5c3b207bb06e902368fd00c0851003b2e385719d850b3cced15e3d4a2b2d5143b5eafc
DIST dict-en-20240501_lo.oxt 6107426 BLAKE2B 811ca6f8a82f348c391b8b4df832446a8d248ec9b6ec85a9c1320f7329679e4fa6d3d507d18d3d792d878fc6f369b70135fa25a75c86b858333e370816db5761 SHA512 3d4ae13c4d68a62970742bb7e8568bebf03cbfaa04051b2152197f2d2a9fb539642a6ff6032123716c31e5f340bd2bad428983f79a7d8c6679e9da48f272e65c
+DIST dict-en-20240601_lo.oxt 6109035 BLAKE2B a90f4f2dad3a0b694aadeddf0a028138cb06f6e9f244279a43741b87260bacefd83148997f99ddca83343a301dc92a84253174e16595c11796a20dda3a372237 SHA512 688ad1a14f6a3eadbcaa7cc9e08ce6fe4bf5d6867fa92df6eb9fc91d06645936ad1844e1fa954e6c9d20aabfa8cb323a99ff9383f70c55b1afcf6685d5970b5e
diff --git a/app-dicts/myspell-en/myspell-en-20240601.ebuild b/app-dicts/myspell-en/myspell-en-20240601.ebuild
new file mode 100644
index 000000000000..e2ef61695d09
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20240601.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="
+ https://extensions.libreoffice.org/extensions/english-dictionaries
+ https://github.com/marcoagpinto/aoo-mozilla-en-dict
+ https://proofingtoolgui.org
+"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/1717313617/dict-en-${PV}_lo.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+PLOCALES=( "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE="${PLOCALES[*]/#/+l10n_}"
+REQUIRED_USE="|| ( ${PLOCALES[*]/#/l10n_} )"
+
+src_prepare() {
+ # This thesaurus is used by all the English dictionaries, see
+ # ./dictionaries.xcu in the distfile, lines 71-81.
+ MYSPELL_THES=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+
+ local non_us_dic_used=0
+ local mylinguas
+ for lang in "${PLOCALES[@]}"; do
+ mylinguas="${lang/-/_}"
+ if use "l10n_${lang}"; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ if [[ ${lang} == en-US ]]; then
+ MYSPELL_HYPH=( "hyph_en_US.dic" )
+ else
+ non_us_dic_used=1
+ fi
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ elif [[ ${lang} == "en-GB" ]]; then
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ if [[ non_us_dic_used -eq 1 ]]; then
+ # This is used by every English variety, except for the en-US, see
+ # ./dictionaries.xcu, lines 60-70.
+ MYSPELL_HYPH+=( "hyph_en_GB.dic" )
+ else
+ rm "README_hyph_en_GB.txt" || die
+ fi
+
+ default
+}