summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-11 22:16:46 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-11 22:18:06 +0200
commita1d3110285a7fd9127d8919cd36d299de4c8fb25 (patch)
tree816c4ed3883679fd947cecea828cde44479baf7a /app-crypt
parentapp-crypt/certbot: enable py3.10 and tests (diff)
downloadgentoo-a1d3110285a7fd9127d8919cd36d299de4c8fb25.tar.gz
gentoo-a1d3110285a7fd9127d8919cd36d299de4c8fb25.tar.bz2
gentoo-a1d3110285a7fd9127d8919cd36d299de4c8fb25.zip
app-crypt/certbot: sync live ebuild with 1.18.0
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index bf9117a89b96..d1f283af9bb4 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python{3_7,3_8,3_9})
+
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
@@ -34,3 +35,5 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest