summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-03-03 10:18:11 +0100
committerHans de Graaff <graaff@gentoo.org>2024-03-03 10:19:21 +0100
commit20d3de6edd2ea5e2369e5dbc5833712b96c4c755 (patch)
tree7e7cd61e08a9194fd8acf98c5ef7a37e5fcb9350 /app-crypt
parentwww-apps/piwigo: drop 14.0.0, 14.1.0 (diff)
downloadgentoo-20d3de6edd2ea5e2369e5dbc5833712b96c4c755.tar.gz
gentoo-20d3de6edd2ea5e2369e5dbc5833712b96c4c755.tar.bz2
gentoo-20d3de6edd2ea5e2369e5dbc5833712b96c4c755.zip
app-crypt/xca: add 2.6.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/xca/Manifest1
-rw-r--r--app-crypt/xca/xca-2.6.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
index a45575a0100b..5a4928531739 100644
--- a/app-crypt/xca/Manifest
+++ b/app-crypt/xca/Manifest
@@ -1 +1,2 @@
DIST xca-2.5.0.tar.gz 1850445 BLAKE2B e12666fc0513cd04bd61d4e182851c055c120425ad8d2fb2698396429b7afb4cc57c77be6d6cc3f63f9d49d5a179123b336d43dde57ef4a3274e7ba1a06f22f7 SHA512 8b283509849c9ac34d5250c780dc0c7a6319eb3201ae892fc2c38e5257d7db4e565e88167a687ffc1ca436068a41cd48fad59d3ecc8235678d46cf026280bd5e
+DIST xca-2.6.0.tar.gz 1874590 BLAKE2B a6a83df88209d6c929bfd5781f6d56b01498d3b9d296a66f4e513f279fc3c14749e1af1f765e863b26e49807a00f5c11e40f8e16f965e23025d835b58eaf4dfc SHA512 4797445e818545c92ded8f611e53f36cab85b527772a531d7a3fae5c5fdb87e1be34139ffeb906239bc3a02221807e2d7c286990ce68f92c1964545cb8fd7986
diff --git a/app-crypt/xca/xca-2.6.0.ebuild b/app-crypt/xca/xca-2.6.0.ebuild
new file mode 100644
index 000000000000..c9e4d8aa423b
--- /dev/null
+++ b/app-crypt/xca/xca-2.6.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit cmake virtualx xdg-utils
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="https://hohnstaedt.de/xca/"
+SRC_URI="https://github.com/chris2511/xca/archive/refs/tags/RELEASE.${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/xca-RELEASE.${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ dev-qt/qthelp:5
+ dev-qt/qtgui:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ dev-libs/openssl:*
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5 doc? ( dev-python/sphinx dev-python/sphinxcontrib-htmlhelp dev-python/sphinxcontrib-qthelp )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+ "${FILESDIR}/${PN}-2.4.0-man-page.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQTFIXEDVERSION=Qt5
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ virtx default
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/xca
+ doins misc/*.txt
+
+ dosym xca /usr/bin/xca-console
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}