summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-12 22:00:01 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-12 22:51:47 -0500
commit7b27d5e663c69e10ff905dcdee6ffa6893b19ff3 (patch)
tree590967ab907a247d5bdb55d809c43b932c97d51d /app-crypt/seahorse
parentapp-text/iso-codes: Version bump to 4.6.0 (diff)
downloadgentoo-7b27d5e663c69e10ff905dcdee6ffa6893b19ff3.tar.gz
gentoo-7b27d5e663c69e10ff905dcdee6ffa6893b19ff3.tar.bz2
gentoo-7b27d5e663c69e10ff905dcdee6ffa6893b19ff3.zip
app-crypt/seahorse: Version bump to 3.38.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/Manifest1
-rw-r--r--app-crypt/seahorse/seahorse-3.38.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
index f1255552e6b8..e10f4b2a20b1 100644
--- a/app-crypt/seahorse/Manifest
+++ b/app-crypt/seahorse/Manifest
@@ -1 +1,2 @@
DIST seahorse-3.36.2.tar.xz 1695824 BLAKE2B e4efb20f952e879b0ff17a9c8664ba61d10c69e377a2fdda52904a8bf5c026d147f9feb9b55c07982f256b366f756dd1567a522d89969c8c5c461f653a130676 SHA512 6a0cb7847fe9917d6d6da31f9b81a4737e425d451fc80604d8e3deb9fa57798f04aa577dae68bc156a15743975f74fbde5ff06a0b05b34228bdc9ef2539b6451
+DIST seahorse-3.38.1.tar.xz 1725480 BLAKE2B 348d9fe1208a9205c58c5655ce97b79c279e2e3506f041a1ebac1f7c83666186ec792bafe7f23b470dd1202a12bc974376b8c369888c6fa194739e7a15973d63 SHA512 1a064ecaf1a25aa84010f914043c3776eba464844598b15e0822217ad330396516df64afed1aeffb3c7b6102d1477c280ec8ec32101cf9f5120c433431b9df32
diff --git a/app-crypt/seahorse/seahorse-3.38.1.ebuild b/app-crypt/seahorse/seahorse-3.38.1.ebuild
new file mode 100644
index 000000000000..031375c4f5c1
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-3.38.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg vala
+
+DESCRIPTION="Manage your passwords and encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="ldap zeroconf"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.58:2
+ >=app-crypt/gcr-3.11.91:=
+ >=app-crypt/gpgme-1.7.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=app-crypt/gnupg-2.0.12
+ gui-libs/libhandy:1=
+ >=app-crypt/libsecret-0.16
+ dev-libs/libpwquality
+ net-misc/openssh
+ ldap? ( net-nds/openldap:= )
+ >=net-libs/libsoup-2.33.92:2.4
+ zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/libxml2:2
+ app-crypt/gcr[vala]
+ app-crypt/libsecret[vala]
+ gui-libs/libhandy:1[vala]
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/appstream-glib
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dhelp=true
+ -Dpgp-support=true
+ -Dcheck-compatible-gpg=false # keep lowest version listed as compatible as min dep for gnupg RDEPEND
+ -Dpkcs11-support=true
+ -Dkeyservers-support=true
+ -Dhkp-support=true
+ $(meson_use ldap ldap-support)
+ $(meson_use zeroconf key-sharing)
+ -Dmanpage=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}