summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHank Leininger <hlein@korelogic.com>2024-05-24 23:42:21 -0600
committerSam James <sam@gentoo.org>2024-05-25 07:46:47 +0100
commit346ff8a2ad1cda68f1b6c4fd79371de15d60f51a (patch)
tree651776e0972512e8516c69aab99638439310ffaa /app-crypt/loop-aes-losetup
parentsys-fs/loop-aes: add nvme boot device support (diff)
downloadgentoo-346ff8a2ad1cda68f1b6c4fd79371de15d60f51a.tar.gz
gentoo-346ff8a2ad1cda68f1b6c4fd79371de15d60f51a.tar.bz2
gentoo-346ff8a2ad1cda68f1b6c4fd79371de15d60f51a.zip
app-crypt/loop-aes-losetup: add 2.40.1
Signed-off-by: Hank Leininger <hlein@korelogic.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/loop-aes-losetup')
-rw-r--r--app-crypt/loop-aes-losetup/Manifest4
-rw-r--r--app-crypt/loop-aes-losetup/loop-aes-losetup-2.40.1.ebuild113
-rw-r--r--app-crypt/loop-aes-losetup/metadata.xml1
3 files changed, 118 insertions, 0 deletions
diff --git a/app-crypt/loop-aes-losetup/Manifest b/app-crypt/loop-aes-losetup/Manifest
index f562291f8628..ea32142a9e07 100644
--- a/app-crypt/loop-aes-losetup/Manifest
+++ b/app-crypt/loop-aes-losetup/Manifest
@@ -1,2 +1,6 @@
DIST loop-AES-v3.8b.tar.bz2 411795 BLAKE2B 51e2c4ddd25f288c5cc5cbbbe20d79951d68bc2b7ecc91fe6eddbb829b297fe6946590512f423efcf5be3c4a1c9ce450c0cf49ed44ac6ad8eb2568468570d48f SHA512 8143649cc9616735cb9a9c8cb8b5c8a709b139e8b41aec444d56c85ef7852d103f657d0d702ffb04783963f0d0e919a6fe4e10b31cd373cd326e546caad90661
+DIST loop-AES-v3.8c.tar.bz2 419257 BLAKE2B dd7fe8e4fbc3b58e11ef5440ea81b65d9a1e92e71a81020b9664ae2387dd36da327fddab85bfc27b23ac2f546b7622526ded1424e2c6cd3659e8998f914151db SHA512 d22b4773f42d47a8f499e3234f64a880248ea6a2c7e96b598ec11d3d674fca09d989ef9bbee254b384c9fe17adb009115bcfb932081a326400120c1c4c828779
+DIST loop-AES-v3.8c.tar.bz2.sign 861 BLAKE2B aa6c3e2b1e0ab604d92ae6c09fed992f629c7f61b7b62e6d073600f72973ace430e5e0964174a40b63eb703ede4f53098c6deb8af13d663e0bb147a2138a6635 SHA512 44ca990fdf55e8c03e85139dfc07dde5ad1cbd3944060ee2c15b3ce54656b7836e7a8839d237a53361c3ba7bdafda39cbbab0f03bd1952e679d1a3a3c2f0930b
DIST util-linux-2.39.2.tar.xz 8362220 BLAKE2B 963c257b86f8a025a3452f102656f479382b9e03dd8ce39b9561302b484c595005aa0bbce9b91422d9be038037143772483363c2a1eec569355316fc8d5d5765 SHA512 cebecdd62749d0aeea2c4faf7ad1606426eff03ef3b15cd9c2df1126f216a4ed546d8fc3218c649fa95944eb87a98bb6a7cdd0bea31057c481c5cf608ffc19a3
+DIST util-linux-2.40.1.tar.sign 833 BLAKE2B 2f8537cd4f52e0c203360d081a91f17c2db13c0f6054ef02f967e8fdf03099bb8c42604864003bfb911ea7804033f4020e2f56a933667fc84ac9c4b8d01e9ed5 SHA512 ab73a27fc8601041bf7b8a088586b78c49ca83cf9c8cfe5877280c0b5c607e95695512804335a8c0ac1d243e4433595f44256407fdbfb053451b8ab40d605502
+DIST util-linux-2.40.1.tar.xz 8823784 BLAKE2B a51fcf9b63c033e470da4f4f0094f0f923fdeb5a649a5c59d2d44888e5e741dfd95e589247355296e050d9ec8dc4334c5898453af055abcb30082af6b835a3e3 SHA512 58ec6eb41d4b6bfc544a80e95c71b5f3798ab4d2a9435d3ee9e5edd56f9b3f09bcb154bdd70e002dc018938937e2e946ae731dcda0f86b362fc43423689e41fc
diff --git a/app-crypt/loop-aes-losetup/loop-aes-losetup-2.40.1.ebuild b/app-crypt/loop-aes-losetup/loop-aes-losetup-2.40.1.ebuild
new file mode 100644
index 000000000000..a893df776342
--- /dev/null
+++ b/app-crypt/loop-aes-losetup/loop-aes-losetup-2.40.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs libtool flag-o-matic verify-sig
+
+MY_PV="${PV/_/-}"
+MY_P="util-linux-${MY_PV}"
+LOOPAES_P="loop-AES-v3.8c"
+
+DESCRIPTION="Loop-AES losetup utility"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/util-linux/util-linux"
+SRC_URI="
+ https://www.kernel.org/pub/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz
+ http://loop-aes.sourceforge.net/loop-AES/${LOOPAES_P}.tar.bz2
+ verify-sig? (
+ https://www.kernel.org/pub/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.sign
+ http://loop-aes.sourceforge.net/loop-AES/${LOOPAES_P}.tar.bz2.sign
+ )
+"
+S="${WORKDIR}/${MY_P}"
+LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="nls selinux static"
+
+RDEPEND="
+ selinux? ( >=sys-libs/libselinux-2.2.2-r4 )
+ verify-sig? (
+ >=sec-keys/openpgp-keys-karelzak-20230517
+ >=sec-keys/openpgp-keys-jariruusu-20240521
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ sys-devel/gettext
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/os-headers
+"
+
+PATCHES=(
+ "${WORKDIR}/${LOOPAES_P}/util-linux-${PV}.diff"
+)
+
+src_unpack() {
+
+ if use verify-sig ; then
+ mkdir "${T}"/verify-sig || die
+ pushd "${T}"/verify-sig &>/dev/null || die
+
+ # Upstream sign the decompressed .tar
+ # Let's do it separately in ${T} then cleanup to avoid external
+ # effects on normal unpack.
+ cp "${DISTDIR}"/${MY_P}.tar.xz . || die
+ xz -d ${MY_P}.tar.xz || die
+ verify-sig_verify_detached ${MY_P}.tar "${DISTDIR}"/${MY_P}.tar.sign /usr/share/openpgp-keys/karelzak.asc
+
+ popd &>/dev/null || die
+ rm -r "${T}"/verify-sig || die
+
+ verify-sig_verify_detached "${DISTDIR}"/${LOOPAES_P}.tar.bz2{,.sign}
+ fi
+
+ default
+}
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ append-lfs-flags
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-all-programs \
+ --disable-libmount-mountfd-support \
+ --disable-liblastlog2 \
+ --disable-pam-lastlog2 \
+ --disable-pylibmount \
+ --enable-libsmartcols \
+ --enable-losetup \
+ --without-btrfs \
+ --without-libz \
+ --without-libmagic \
+ --without-ncurses \
+ --without-ncursesw \
+ --without-python \
+ --without-readline \
+ --without-systemd \
+ --without-tinfo \
+ --without-udev \
+ --without-util \
+ $(use_enable nls) \
+ $(use_with selinux) \
+ $(tc-has-tls || echo --disable-tls) \
+ $(use_enable static) \
+ $(use static && echo --enable-static-programs=losetup)
+}
+
+src_install() {
+ emake install DESTDIR="${T}/root"
+ newsbin "${T}/root/sbin/losetup" loop-aes-losetup
+ newman "${T}/root/usr/share/man/man8/losetup.8" loop-aes-losetup.8
+ use static && newsbin "${T}/root/bin/losetup.static" loop-aes-losetup.static
+}
diff --git a/app-crypt/loop-aes-losetup/metadata.xml b/app-crypt/loop-aes-losetup/metadata.xml
index 51566655bb4b..d1f684c0460f 100644
--- a/app-crypt/loop-aes-losetup/metadata.xml
+++ b/app-crypt/loop-aes-losetup/metadata.xml
@@ -10,6 +10,7 @@
<name>Proxy Maintainers</name>
</maintainer>
<upstream>
+ <remote-id type="github">util-linux/util-linux</remote-id>
<remote-id type="sourceforge">loop-aes</remote-id>
</upstream>
</pkgmetadata>