summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-08-31 09:28:29 -0700
committerSam James <sam@gentoo.org>2022-09-01 03:15:51 +0100
commit2decb35d9c92550ed0688745039751b38dd5b916 (patch)
tree4b32546a78050c4a65580ba7818df9f92c272e0e /app-crypt/gpa/gpa-0.10.0-r1.ebuild
parentapp-crypt/scute: Remove outdated configure args (diff)
downloadgentoo-2decb35d9c92550ed0688745039751b38dd5b916.tar.gz
gentoo-2decb35d9c92550ed0688745039751b38dd5b916.tar.bz2
gentoo-2decb35d9c92550ed0688745039751b38dd5b916.zip
app-crypt/gpa: Backport upstream autoconf fixes
Bug: https://bugs.gentoo.org/844226 Upstream-commit: https://dev.gnupg.org/rGPAb40ff3b1f20dec3b14ca72d0af50137e38cd1808 Closes: https://github.com/gentoo/gentoo/pull/27083 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/gpa/gpa-0.10.0-r1.ebuild')
-rw-r--r--app-crypt/gpa/gpa-0.10.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/gpa/gpa-0.10.0-r1.ebuild b/app-crypt/gpa/gpa-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..f8dd22fbdcb4
--- /dev/null
+++ b/app-crypt/gpa/gpa-0.10.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+DESCRIPTION="The GNU Privacy Assistant (GPA) is a graphical user interface for GnuPG"
+HOMEPAGE="http://gpa.wald.intevation.org"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ >=app-crypt/gnupg-2:=
+ >=app-crypt/gpgme-1.11.1:=
+ >=dev-libs/libassuan-1.1.0:=
+ >=dev-libs/libgpg-error-1.4:=
+ >=x11-libs/gtk+-2.10.0:2=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autoconf.patch
+)
+
+src_prepare() {
+ default
+ sed -i 's/Application;//' gpa.desktop
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ GPGKEYS_LDAP="/usr/libexec/gpgkeys_ldap"
+}